












	
	
		
	
		
	
	
	
	
		
	


<!DOCTYPE html>
<!--[if lt IE 7]>  <html lang="en" class="lt-ie9 lt-ie8 lt-ie7" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 7]> <html lang="en" class="lt-ie10 lt-ie9 lt-ie8" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 8]> <html lang="en" class="lt-ie10 lt-ie9" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="lt-ie10" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" xmlns="http://www.w3.org/1999/xhtml" xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->
	
	











<head>
	<link rel="alternate" hreflang="en" href="https://www.csoonline.com/article/3440580/magecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html" />
	
	
	
	<!-- metas -->
	<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />		
	<title>Magecart web skimming group targets public hotspots and mobile users | CSO Online</title>
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	
	
	<script>
	function getQueryVariable(variable) {
		var query = window.location.search.substring(1);
		var vars = query.split("&");
		for (var i=0;i<vars.length;i++) {
			var pair = vars[i].split("=");
			if(pair[0] == variable){return pair[1];}
		}
		return(false);
	}
	</script>
		
	<!-- ad-related js -->
	<script src="/www/js/jquery/jquery-1.10.2.min.js"></script>
	
	<script type="text/javascript" src="/www/js/jquery/jquery_cookie.js"></script>
	
	
	
	<script type="text/javascript" src="/www/js/apollo-locales.js?v=20190924111950"></script>
	
	
	












<script>
var consent = consent || {};
consent.isEU = consent.isEU || null;
consent.personalization = consent.personalization || null;
consent.ads = consent.ads || {};
consent.ads.queue = consent.ads.queue || [];

consent.infostorage = consent.infostorage || {};
consent.infostorage.queue = consent.infostorage.queue || [];

consent.adsel = consent.adsel || {};
consent.adsel.queue = consent.adsel.queue || [];

consent.contentsel = consent.contentsel || {};
consent.contentsel.queue = consent.contentsel.queue || [];

consent.socmedia = consent.socmedia || {};
consent.socmedia.queue = consent.socmedia.queue || [];

consent.tealium = consent.tealium || {};
consent.tealium.queue = consent.tealium.queue || [];

consent.digitalelement = consent.digitalelement || {};
consent.digitalelement.queue = consent.digitalelement.queue || [];

consent.purposes = consent.purposes || {};
consent.purposes.standard = consent.purposes.standard || [];
consent.purposes.custom = consent.purposes.custom || [];
consent.vendors = consent.vendors || {};
consent.vendors.standard = consent.vendors.standard || [];
consent.vendors.custom = consent.vendors.custom || [];

var dataLayer = window.dataLayer = window.dataLayer || [];
</script>



<style type="text/css">
#sp_privacy_manager_container {
	z-index: 10000000 !important;
}
</style>

<script> 											
window._sp_ = window._sp_ || {};
window._sp_.config = window._sp_.config || {};

//Replace YOUR_ACCOUNT_ID with the account ID provided
//by Sourcepoint
window._sp_.config.account_id = 146;

// replace 'mms.sp-prod.net' with your CNAME'd messaging subdomain		
window._sp_.config.mms_domain = 'cmp.csoonline.com' ; 
//window._sp_.config.mms_domain = 'mms.sp-prod.net' ; 

// messaging-specific configuration
window._sp_.mms = window._sp_.mms || {};
window._sp_.mms.cmd = window._sp_.mms.cmd || [];

//CMP Flags
window._sp_.config.cmp = _sp_.config.cmp || {};
window._sp_.config.cmp.enabled = true;
window._sp_.config.cmp.waitForConsentData = true;

//Code to call the server and display a message
window._sp_.mms.cmd.push( function () {
    window._sp_.mms.startMsg();
});						
</script>

<script src="//d2zv5rkii46miq.cloudfront.net/0/latest/cmp_shim.js"></script>
<script src="/www/js/messaging.js"></script>



<script>
__cmp('getConsentData',null,function(e){
	
	consent.isEU = e.gdprApplies;
	if (!consent.isEU) {
		
		consent.personalization=true;
		$(window).trigger("runConsent", [consent.ads.queue]);
		$(window).trigger("runConsent", [consent.infostorage.queue]);
		$(window).trigger("runConsent", [consent.adsel.queue]);
		$(window).trigger("runConsent", [consent.contentsel.queue]);
		$(window).trigger("runConsent", [consent.socmedia.queue]);
		$(window).trigger("runConsent", [consent.digitalelement.queue]);
		$(window).trigger("runConsent", [consent.tealium.queue]);
		dataLayer.push({
			'event': 'consentKnown' 
		});
	}
	else if (e.consentData !== null && e.consentData !== "") { // else if.. visitor is from EU and consent is known...
		getConsentInfo();
		bindReshowCmp();
	}
	else { //else consent is not known
	    bindReshowCmp();
	}
});

function getConsentInfo() {
	
	__cmp('getVendorConsents',[],function (e) {
		
		consent.purposes.standard = Object.keys(e.purposeConsents);
		consent.vendors.standard = Object.keys(e.vendorConsents);
		
		consent.personalization = consent.purposes.standard.includes("2");
		
		
		
		
		
		
		
		if (consent.purposes.standard.includes("1")) { // if information storage consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.infostorage.queue]);
		}
		if (consent.purposes.standard.includes("3")) { // if ad selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.adsel.queue]);
		}
		if (consent.purposes.standard.includes("4")) { // if content selection consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.contentsel.queue]);
		}
		//special case for Tealium
		if (consent.purposes.standard.includes("1") && consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5") && consent.vendors.standard.includes(522)) {
			
			$(window).trigger("runConsent", [consent.tealium.queue]);
		}
		
		//special case for Digital Element
		if (consent.purposes.standard.includes("2") && consent.purposes.standard.includes("3") && consent.purposes.standard.includes("4") && consent.purposes.standard.includes("5")) {
			
			$(window).trigger("runConsent", [consent.digitalelement.queue]);
		}
	});

	__cmp('getCustomVendorConsents',[],function (e) { 
		
		consent.purposes.custom = [];
		e.consentedPurposes.forEach(function(item, index) {
			consent.purposes.custom.push(item.name);
		});
		
		consent.vendors.custom = [];
		e.consentedVendors.forEach(function(item, index) {
			consent.vendors.custom.push(item.name);
		});
		
		
		
		if (consent.purposes.custom.includes("Social Media Consents")) { // if social media consent is TRUE run queue
			
			$(window).trigger("runConsent", [consent.socmedia.queue]);
		}
		
		
		if (consent.vendors.custom.includes("Google Ad Manager")) {
			
			$(window).trigger("runConsent", [consent.ads.queue]);
		}
		
	});
	
	dataLayer.push({
		'event': 'consentKnown' 
	});
}

var idgCMPSourcepointCallback = function(){
	if (consent.isEU) {		
		getConsentInfo();
	}
}

$(window).on("runConsent", function(event, queueToRun) {
		watchConsentQueue(queueToRun)
});

function runQueue(queue){
	for (var x=0;x<queue.length;x++) {
		var nextFn = queue.shift();
		nextFn();
		
	}	
}

function watchConsentQueue(queue){
	setInterval(function() { runQueue(queue); },500);
}
function bindReshowCmp() {
	var url = document.location.pathname;
	if (url.indexOf("/about/member-preferences") > -1) {
		$(document).ready(function() {
			$(".cmpSettings").show();
			$(".reshowLink").on("click", function(e) {
				e.preventDefault();
				window._sp_.privacyManager.loadPrivacyManagerModal(3918, '5cd195e5f9f3332a80a0e25f');
			});
		});
	}
}
</script>




	
	
		<script src="//cdn.blueconic.net/idg.js"></script>
	
	
	
		










<script>
// this javascript is for retrieving locale-specific ad units for DFP - see mapping in apollo-locales.js
// getting locale and editions for the site the reader is viewing
let brandAbbrev = "cso";
let brandConfigBrandId = "32";
//let myLocale = getLocale(); // getting locale on page load from URL, IP, geolocation - this will always be something. If 0, it's the global/default/core view.
let countryCode = "";
let getSlugFromId = getApolloLocaleIdMap();
let getIdFromSlug = getApolloLocaleSlugMap();

// if selectedLocale cookie exists, get locale
if (typeof getSelectedLocale() !== 'undefined'  && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
 	countryCode = getSlugFromId[getSelectedLocale()];
} else {
	countryCode = getSlugFromId[getLocale()];
}
//console.log("+++ 1) in locales.editions.jsp - COUNTRY CODE IS DEFINED AS: "+countryCode+"+++");
// if countryCode is empty string at this point, it means localeId = 0 which is global (default/core)...
if (countryCode == "") {
	countryCode = "us"; // country code for default global is currently US
}
//console.log("====INSIDE locales-editions.jsp - getSelectedLocale() = " + getSelectedLocale() + " and getLocale() = " + getLocale() + " and countryCode = " + countryCode);
//US social media accounts are the default if locale cannot be determined
var twitterUrl = "https://twitter.com/csoonline";
var linkedInUrl = "http://www.linkedin.com/company/csoonline";
var facebookUrl = "https://www.facebook.com/CSOonline";
var youTubeUrl = "";
var twitterHandle = "csoonline";

if (countryCode === 'asean') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'middle-east') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
}
if (countryCode === 'uk') {
	twitterUrl = "https://twitter.com/csoonline";
	linkedInUrl = "http://www.linkedin.com/company/csoonline";
	facebookUrl = "https://www.facebook.com/CSOonline";
	twitterHandle = "";
}
if (countryCode === 'in') {
	twitterUrl = "https://twitter.com/cso_india";
	linkedInUrl = "";
	facebookUrl = "https://www.facebook.com/CSOOnlineIndia/";
	twitterHandle = "CSO_India";
	youTubeUrl = "";
}
if (countryCode === 'africa') {
	twitterUrl = "";
	linkedInUrl = "";
	facebookUrl = "";
	twitterHandle = "";
	youTubeUrl = "";
}

//US business unit is the default if locale cannot be determined
var busUnit = "IDG Communications, Inc.";
//cookie policy page
var localeEdition = "United States Edition";
var busUnitAddress = "IDG Communications, Inc. (“IDGC”)<br>5 Speen Street<br>Framingham, Massachusetts 01701<br>United States of America";
if (countryCode === 'asean') {
	busUnit = "IDG Communications, Inc.";
	localeEdition = "ASEAN Edition";
	busUnitAddress = "IDG Communications, Inc. (“IDGC”)<br>5 Speen Street<br>Framingham, Massachusetts 01701<br>United States of America";
}
if (countryCode === 'middle-east') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
if (countryCode === 'uk') {
	busUnit = "IDG Communications Ltd.";
	localeEdition = "United Kingdom Edition";
	busUnitAddress = "IDG Communications Ltd<br>101 Euston Road<br>London<br>NW1 2RA<br>United Kingdom";
}
if (countryCode === 'in') {
	busUnit = "IDG Media Private Ltd";
	localeEdition = "India Edition";
	busUnitAddress = "IDG Media Pvt Ltd<br>Geeta Building,<br>No 49, 3rd Cross, Mission Road<br>Near Richmond Circle,<br>Bangalore - 560027<br>India";
}
if (countryCode === 'africa') {
	busUnit = "";
	localeEdition = "";
	busUnitAddress = "";
}
</script>

	
	
	<script src="/www/js/init_device.js"></script>
	
	

	

	
		
			















	<script async="async" src="//cdn.adsafeprotected.com/iasPET.1.js"></script>




	<script async src="//js-sec.indexww.com/ht/p/183980-47728333013839.js"></script>

	
<script type="text/javascript" src="/www/js/ads/gpt_includes.js?v=20190924111950"></script>

<script type="text/javascript">
	if (adLayer==null || adLayer=='undefined') {
		var adLayer=[];
	}
	
		
			adLayer["itemType"]="article";
		
		
	
</script>
	
<script type="text/javascript">
	// Set up ad related variables
	try {
		IDG.GPT.unitName = "/8456/IDG.G_B2B_CSOOnline.com";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}

	try {
		IDG.GPT.unitName = IDG.GPT.unitName + "/" + "security_section";
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	// global variables
	var global_ShowSuper = true;
	var global_ShowHero = false;
	
	//XFP global targeting, more targeting thm_pre
	var url = window.location.href;
	if(url.indexOf("?")>1){
		url=url.split('?')[0];
	}
	

	try {
		IDG.GPT.addTarget("URL", encodeURIComponent(url));
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}
	try {IDG.GPT.addTarget("zone", 'article/fraud');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("channel", 'physical-security,malware');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("articleId", '3440580');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("type", 'news');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("typeId", '2');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("manufacturer", 'ibm');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}try{IDG.GPT.addTarget("templateType", 'article-default');}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	
	try {IDG.GPT.addTarget("categoryIds", ['3507','3718','3513','2206']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try{IDG.GPT.addTarget("categorySlugs", ['fraud','cyberwarfare','malware','security']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {IDG.GPT.addTarget("goldenIds", ['986','945','67','941']);}	catch (exception) {console.log ("google_dfp can't use IDG.GPT "+ exception);}
	try {
		if (null != IDG.GPT.getQsVal("env")) {		
			IDG.GPT.addTarget("env", IDG.GPT.getQsVal("env").replace(/\W/g, "") );
		}
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	
	
		try {
			IDG.GPT.addTarget("author", 'Lucian Constantin');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
		

	try {
		IDG.GPT.addTarget("page_type", '');
	}
	catch (exception) {
		console.log ("google_dfp can't use IDG.GPT "+ exception);
	}	

	
	
	
	
		try {
			IDG.GPT.addTarget("insiderContent", 'false');
		}
		catch (exception) {
			console.log ("google_dfp can't use IDG.GPT "+ exception);
		}
	
	
	
	
	
</script>



<script type="text/javascript">
	
	
	
	
		
		
		
		
		
		
		
		
	
	
	
			try {
					IDG.GPT.isNewHeader = true;
				}
				catch (exception) {
					console.log ("google_dfp can't use IDG.GPT "+ exception);
				}
	
	
</script>
  
<script src="/www.idge/js/thm_pre.js?v=20190924111950"></script>


	
	
		<script>
		// IDGMPM-16419 - moved out of adsel queue for IDGMPM-16933
		googletag.cmd.push(function() {
		  if (googletag.pubads().getTargeting('permutive').length == 0) {
		    var kvs = localStorage.getItem('_pdfps');
		    googletag.pubads().setTargeting('permutive', kvs ? JSON.parse(kvs) : []);
		    console.log('ad targeting permutive kvs: ', kvs);
		  }
		});
		</script>
	

<script type="text/javascript" src="/www/js/ads/gpt_starter.js?1234"></script>
	<script>
		loadGPT();
	</script>

	
		<script type="text/javascript" src="/www/js/ads/ias_gpt_launcher.js?v=20190924111950"></script>
	

	



		
		
	
	
	
		
				
		
		
		
	

	<link rel="canonical" href="https://www.csoonline.com/article/3440580/magecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html" />
	
	
		
	

	<meta itemprop="url" content="https://www.csoonline.com/article/3440580/magecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html" />
	<meta name="description" content="IBM researchers discover new Magecart scripts suggest planned advertisement injection through Wi-Fi and supply chain attacks." />
	
		
			<meta name="DC.date.issued" content="2019-09-25T04:10-05:00" />
			<meta name="date" content="2019-09-25" />
			
		
		
		
		
	
	
	<link rel="amphtml" href="https://www.csoonline.com/article/3440580/magecart-web-skimming-group-targets-public-hotspots-and-mobile-users.amp.html" />
	
		
		
		
			
			
				
			
			
			
		
	
	
		
		
			<meta property="og:title" content="Magecart web skimming group targets public hotspots and mobile users">
		
	
	<meta property="og:description" content="IBM researchers discover new Magecart scripts suggest planned advertisement injection through Wi-Fi and supply chain attacks.">	
	
	
		
			<meta property="og:image" content="https://images.idgesg.net/images/article/2019/06/online-shopping-cart_magecart_hackers_shopping-online-100798500-large.3x2.jpg" />
			<meta property="og:image:width" content="1200" />
			<meta property="og:image:height" content="800" />
			<meta itemprop="image" content="https://images.idgesg.net/images/article/2019/06/online-shopping-cart_magecart_hackers_shopping-online-100798500-large.3x2.jpg">
			<meta itemprop="thumbnailURl" content="https://images.idgesg.net/images/article/2019/06/online-shopping-cart_magecart_hackers_shopping-online-100798500-large.3x2.jpg" />
			<link rel="image_src" href="https://images.idgesg.net/images/article/2019/06/online-shopping-cart_magecart_hackers_shopping-online-100798500-large.3x2.jpg" />
			<meta name="twitter:image" content="https://images.idgesg.net/images/article/2019/06/online-shopping-cart_magecart_hackers_shopping-online-100798500-large.3x2.jpg" />
		
		
	
	
		
			<meta property="og:type" content="article" />
			
			
			
			
			
			
			
			
			
			<meta name="author" content="Lucian Constantin">
			
			
			
			
			
		
		 
		
	<meta property="og:site_name" content="CSO Online" />
	<meta property="fb:app_id" content="147046808648758" />
	
		
			<meta property="og:url" content="https://www.csoonline.com/article/3440580/magecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html">
		
		
	
	
	<!-- Use Twitter Summary Card with Large Image for articles and videos -->
	
		
				<meta name="twitter:card" content="summary_large_image">
		
		
	

	<meta name="twitter:site" content="@csoonline">
	<meta name="twitter:description" content="IBM researchers discover new Magecart scripts suggest planned advertisement injection through Wi-Fi and supply chain attacks.">

	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
	<meta name="rating" content="General">
	
	<meta name="robots" content="NOODP,NOYDIR" />
	
	
		<meta name="google-site-verification" content="kKrBZpBg8lV-8uPnwdrHwxRDGrI76jJkp4iUgs2mmBk" />
	
	
	
		<meta name="msvalidate.01" content="04917178B598F0648B9BAD693FEC29A3" />
	
		
	<!-- pagination -->
	
	
	
	
	
	
	
	
	
	
		<link id="mobile-size" rel="stylesheet" href="/www.idge/css/inline-header-mobile.css?v=20190924111950" />
		
		<script>
			if (window.matchMedia("(min-width: 768px)").matches) {
				document.getElementById('mobile-size').insertAdjacentHTML('afterend', '<link id="desktop-size" rel="stylesheet" href="/www.idge/css/inline-header.css?v=20190924111950" />');
			}
		</script>
		
			
				<link rel="stylesheet" href="/www.idge.cso/css/inline-header.css?v=20190924111950" />
			
		
	
	
	<!-- css -->
	<link rel="stylesheet" href="/www.idge/css/normalize.css" />
	<link rel="stylesheet" href="/www.idge/css/prettify.css" />
	
		<link rel="stylesheet" href="/www.idge.ans/js/select2-3.5.0/select2.css" />
	
	
	
		
			
			
			
			
				
					
						
						
						
							<link rel="stylesheet" href="/www/css/article.css?v=20190924111950" />
						
					
					
					
					
			
				
		
		
		
			<link rel="stylesheet" href="/www.idge/css/insider-promo-styles.css?v=20190924111950" />
		
		<link rel="stylesheet" href="/www.idge/css/print.css" media="print" />
		
	
	
		
			
			
				
				
					<link rel="stylesheet" href="/www.idge.cso/css/article.css?v=20190924111950" />
				
			
		
	
	
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-social.css" />
	<link rel="stylesheet" href="/www.idge/css/webfonts/ss-standard.css" />
	<!--[if lte IE 8]>  
		<link href="/www.idge/css/webfonts/ss-ie8.css" rel="stylesheet" />
	<![endif]--> 
	
	
	
	
		
	
	
	
		<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.6.1/css/all.css" integrity="sha384-gfdkjb5BdAXd+lj+gudLWI+BXq4IuLW5IT+brZEZsLFm++aCMlF1V92rMkPaX4PP" crossorigin="anonymous">
	
	
	
		<link rel="stylesheet" href="https://use.typekit.net/xyb0fnv.css" />
	
	
	<!--  fav and touch icons -->
	<link rel="shortcut icon" type="image/x-icon" href="https://idge.staticworld.net/cso/favicon.ico"/>
	<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://idge.staticworld.net/cso/CSO_logo_144x144.png" />
	<link rel="apple-touch-icon-precomposed" sizes="114x114" href="https://idge.staticworld.net/cso/CSO_logo_114x114.png" />
	<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://idge.staticworld.net/cso/CSO_logo_72x72.png" />
	<link rel="apple-touch-icon-precomposed" sizes="57x57" href="https://idge.staticworld.net/cso/CSO_logo_57x57.png" />
	<link rel="apple-touch-icon" href="https://idge.staticworld.net/cso/CSO_logo_300x300.png" />
	
	
		<script src="/www.idge.ans/js/select2-3.5.0/select2.js"></script>
	
	
	
	
	
	
		<script>
		   $(document).ready(function() { 
			   $("select#country").select2({
			    	placeholder: "country",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    });
			   $("select#state").select2({
			    	placeholder: "state",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    });
			    $("#jobPosition").select2({
			    	placeholder: "position",
			    	minimumResultsForSearch: Infinity,
			    	allowClear: true
			    }); 
			   	$("#jobFunction").select2({
			   		placeholder: "function",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	}); 
			   	$("#companySize").select2({
			   		placeholder: "company size",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	});
			   	$("#industry").select2({
			   		placeholder: "industry",
			   		minimumResultsForSearch: Infinity,
			    	allowClear: true
			   	}); 
		   });
	   </script>
   	    
   	     











<script>
var isProd = 'true';

var brandCode = "cso";
var brandName="CSO Online";
var brandId = "2";
var regDebugLog=false;

// Marketing Channels Preference
var brandIdDemandgen=false;
var brandIdEvents=false;
var brandIdResearch=false;
var brandIdThirdparty=false;
var isEu=false;

// API URL and API key
var regApiUrl='https://api-stage.idgcommunications.net/api/v1/'; // replaced below with property in .properties file
var apiKey="HLyMXLISSW7HAYGgbx2Vb1Gf1OLcGmMG5BcwZ4Vb";

var tokenPrefix='www';
var tokenSuffix='.com/insider/token?';
var brandDomain=".csoonline.com";
var insiderContentType="article";
var notEmptyArticle=false;
var notEmptyMediaResource=false;
var isInsiderPremium=false;
var isResourceInsiderPremium=false;

var ownerIds=["0c99a1d7-c4e7-42a5-910f-a22134d1f98d"];
var campaignId="2a3b7224-f920-41a1-bea6-615aa59ea0f8";
var assetId="697422d1-7acb-40f6-be13-0e67329bc9ec";
var placementId="2d44d74a-e883-4d18-ada8-b2f0e61a1d90";
var clientCompany="IDG Communications US";
var businessUnit="IDG Communications US";

if (countryCode == 'uk') {
	brandId = "94";
	ownerIds=["f3efa90a-2330-4d42-bbc7-f7f96eb0f3db"];
	campaignId="a465ea50-b639-4f98-ad1c-bc0b8c80e3c9";
	assetId="5ab2586f-3bb6-4ad3-84e2-bdd230980e88";
	placementId="77a1e657-f12c-4f7c-b685-6a9da2eb25d6";
	clientCompany="IDG Communications";
	businessUnit="IDG UK";
}
if (countryCode == 'africa') {
	brandId = "";
	ownerIds=["02b2821f-2118-442a-9f16-df416847133f"];
	campaignId="89c3e1d5-f5c6-4934-b683-751414ffe5b7";
	assetId="8848c7a9-7ed0-4119-ba20-e9f06869928c";
	placementId="7d80c555-1916-4c7b-bd56-dd10767d83b8";
	clientCompany="IDG Communications";
	businessUnit="IDG Connect";
}
if (countryCode == "asean") {
		brandId = "";
		ownerIds=["02b2821f-2118-442a-9f16-df416847133f"];
		campaignId="77f2f4c1-c3f3-4796-be52-d44c982bc824";
		assetId="59fdb971-7da7-48a0-bd6d-e52db502b83f";
		placementId="b1f22813-ff0d-42d8-90d9-c1fbd47b3424";
		clientCompany="IDG Communications";
		businessUnit="IDG Connect";
}
if (countryCode == 'mideast' || countryCode == 'middle-east' ) {
		brandId = "";
		ownerIds=["02b2821f-2118-442a-9f16-df416847133f"];
		campaignId="2e8ce243-c3b2-417b-a893-ba4fb496776b";
		assetId="511c10e5-69b7-4a0d-861f-99b048e129f8";
		placementId="59a18947-cead-4faf-8d94-2fd9bba346a4";
		clientCompany="IDG Communications";
		businessUnit="IDG Connect";
}
if (countryCode == 'in') {
		brandId = "57";
		ownerIds=["b6973a30-3c15-4667-9165-e206b8876adc"];
		campaignId="cf43ee09-cb17-4704-aec9-3c3faefee27f";
		assetId="f411310d-fa2f-4518-93c9-e08962d736b2";
		placementId="6813ef80-eb35-4d48-94f0-4b64c406ca52";
		clientCompany="IDG Communications";
		businessUnit="IDG India";
}


	regApiUrl="https://lqxgcyk808.execute-api.us-east-1.amazonaws.com/prod_h2/api/v1/";



	regDebugLog=false;



	tokenPrefix="http://www";



	tokenSuffix="/insider/token";





	notEmptyArticle=true;


	



 

</script>


<script src="/www/js/utils/alc_hashes.js"></script>
<script src="/www/js/insider/insider_reg_api.js?v=20190924111950"></script>
<script src="/www/js/insider/jquery.maskedinput-1.4.min.js"></script>

<script>
$(document).ready(function(){
	if(typeof(IDG.insiderReg.readCookie('nsdr')) !== 'undefined'){
		$('#welcome-message').show();			
		IDG.insiderReg.personalize();
	}else{
		$('.signin-register').show();	
	}
});

</script>


	



	

	
	
	
	
















	

	
	<script src="/www/js/ads/ads.js"></script>
	
	<script>var oneRegPlacementID = "";</script>
	
	<script>
		const articlePaidAccess = [];
	</script>
	
	
	
		
			
				
			
			
			
			
			
			
			
			

				
			
		
		
		
	
	
	
	
	
	
	





	
		
	
		
	
	





		
		  
		
		
		
		

	
	
	
	
	

	
	  	 
	    
	    
	 
	 
	
	
	
	
	
	
	
	
		
	
	

	<script>
	var supMontMods = false;
	</script>
	
	
	
	
		
		
		
			
				
				
			











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2806 blox4.simple  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		















	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	
		
		
	


	


		
	
	
	
	
	
	
		
			
		
			
		
			
		
			
		
	
	
	
	
	
	
	
	
	
		
			
				
				
				
					
				
			
			
			
			
		
		
		
	
	
	
	
	
	
	
	

	
	
	
	
	
		<script>
		window.ntvConfig = window.ntvConfig || {} ;
		window.ntvConfig.keyValues = window.ntvConfig.keyValues || {};
		var segs = localStorage.getItem('_pnativo');
		if (segs) {
		  window.ntvConfig.keyValues.permutive = JSON.parse(segs).join(",");
		}
		</script>
	
	
	
	
		<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
	

	
	
	
	<script type="text/javascript">
		var prodNames = '';
		var prodManufacturers = '';
		var prodCategories = '';
		var prodVendors = '';
	</script>
	
	
	
	<script>
	var insiderSignedIn = document.cookie.indexOf("nsdr") > -1; //check if Insider cookie exists
	var idg_uuid = $.cookie('idg_uuid') || '';
	
	var dlJobFunction = '';
	var dlJobPosition = '';
	var dlIndustry = '';
	
	if (insiderSignedIn) {
		var insiderToken = IDG.insiderReg.readCookie("nsdr");
		var tokens = IDG.insiderReg.readCookieProperty(insiderToken);
		if (!(tokens['jobPosition']===undefined)) {
			//dlJobPosition = tokens['jobPosition'];
			//OC-1647 change to indicate this data was remove
			dlJobPosition = "removed";
		}
		if (!(tokens['jobFunction']===undefined)) {
			dlJobFunction = tokens['jobFunction'];
		}
		if (!(tokens['industry']===undefined)) {
			dlIndustry = tokens['industry'];
		}
	}
	
	insiderSignedIn = insiderSignedIn.toString(); //per Infotrust this needs to be a string, not a boolean
	
	var sincePublished = '1 days';
	sincePublished = sincePublished.split(" ")[0];
	
	//get edition from countryCode
	var edition = '';
	if (typeof countryCode !== 'undefined' && countryCode !== "") {//should be defined in locales-editions.jsp if brand has editions
		edition = countryCode.toLowerCase();
	}
	
	dataLayer.push({
		'articleId': '3440580',
		'articleDisplayId':'1',
		'articleHasVideo':'false',
		'articleLocale': 'global',
		'articleTitle': 'Magecart web skimming group targets public hotspots and mobile users',
		'articleType': 'News',
		'audience':'enterprise',
		'author':'Lucian Constantin',
		'blogName':'',
		'brandpost': 'false',
		'categoryIdList':'3507,3718,3513,2206',
		'categoryIdPrimary': '3507',
		'contentStrategy': '',
		'contentType':'news',
		'datePublished':'2019-09-25',
		'dateUpdated':'2019-09-25',
		'daysSincePublished':"1",
		'daysSinceUpdated':'1',
		'de_normalized_company_name':$.cookie('de_normalized_company_name'),
		'displayType':'article',
		'edition':edition,
		'environment':'production',
		'ga_enabled':'true',
		'gaTrackingId':'UA-300704-9',
		'geolocEnabled':'true',
		'goldenTaxonomyIdPrimary': '986',
		'goldenTaxonomyIdList': '945,67,941',
		'industry': dlIndustry,
		'insiderSignedIn':insiderSignedIn,
		'ip_normalized_company_name':$.cookie('ip_normalized_company_name'),
		'isBlog':'false',
		'isInsiderContent':'false',
		'isICN': 'false',
		'jobFunction': dlJobFunction,
		'jobPosition': dlJobPosition,
		'oneRegPlacementID':oneRegPlacementID,
		'pageNumber':'1',
		'platform':'Web',
		'podcastSponsored': 'false',
		'primaryCategory': 'fraud',
		'ancestorGoldenCategories': 'compliance,cso',
		'primaryCategoryList': 'cyber attacks,malware,security',
		'primaryAncestorCategoryList': 'compliance,fraud,hacking,cso',
		'prodCategories':prodCategories.slice('|', -1),
		'prodManufacturers':prodManufacturers.slice('|', -1),
		'prodNames':prodNames.slice('|', -1),
		'prodVendors':prodVendors.slice('|', -1),
		'property': 'cso online',
		'propertyCountry':'US',
		'purchaseIntent':'notapplicable',
		'skimlinksId':'111346X1569475',
		'source':'cso',
		'sponsorName':'',
		'suppressMonetization': supMontMods.toString(),
		'tags': '',
		'userId':idg_uuid,
		'videoAutoplay':'false',
		'youtubeId':''
	});
	</script>
	
	












	
<script type="text/javascript">
	var _sf_async_config={};

	_sf_async_config.uid = 29363;

	_sf_async_config.path = "/article/3440580/magecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html";
	_sf_async_config.title = "Magecart web skimming group targets public hotspots and mobile users | CSO Online";
	_sf_async_config.domain = "csoonline.com";
	if(window.location.href.indexOf("video")&&true) {
		_sf_async_config.playerdomain= _sf_async_config.domain.replace("www.","");
	}
	
	_sf_async_config.useCanonical = true;
	
		
			
			_sf_async_config.sections = "fraud";
			_sf_async_config.authors="Lucian Constantin";
			
		
	
</script>



	
	
	
	
	
	










<script>
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var adBlockStatus = 'false';
	
	function AdBlockEnabled() {
		var ad = document.createElement('ins');
		ad.className = 'AdSense';
		ad.style.display = 'block';
		ad.style.position = 'absolute';
		ad.style.top = '-1px';
		ad.style.height = '1px';

		if (document.body != null) {
			document.body.appendChild(ad);
			var isAdBlockEnabled = !ad.clientHeight;
			document.body.removeChild(ad);
		}

		return isAdBlockEnabled; 
	}
	// AdBlockEnabled() was successful document.body not null
	if (AdBlockEnabled() != undefined) {
		adBlockStatus = AdBlockEnabled().toString();
	}
	// not successful - look for ads.js
	if (document.body == null) {
		if (window.canRunAds === undefined) {
			adBlockStatus = 'true';
		} else {
			adBlockStatus = 'false';
		}
	}
	
	dataLayer.push({
		'adBlockStatus': adBlockStatus
	});
</script>





	<!-- Google Tag Manager -->
	<noscript><iframe src="//www.googletagmanager.com/ns.html?GTM-WR6LD2P"
	height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-WR6LD2P');</script>
	<!-- End Google Tag Manager -->

	
	
	
	

	<script src="https://www.google.com/recaptcha/api.js" async defer></script>
	
	
	
		<script>
			var numberFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "number") {
			    return dataLayer[0][property];
			  }
			  return null;
			};
			
			var stringFromDataLayer = function(property) {
			  if (window.dataLayer && dataLayer[0] && typeof dataLayer[0][property] == "string") {
			    return dataLayer[0][property];
			  }
			  return "";
			};
		</script>
	

	

	
		










<script>
// IDGMPM-16419 - updated in IDGMPM-16933
	!function(n,e,o,r,i){if(!e){e=e||{},window.permutive=e,e.q=[],e.config=i||{},e.config.projectId=o,e.config.apiKey=r,e.config.environment=e.config.environment||"production";for(var t=["addon","identify","track","trigger","query","segment","segments","ready","on","once","user","consent"],c=0;c<t.length;c++){var f=t[c];e[f]=function(n){return function(){var o=Array.prototype.slice.call(arguments,0);e.q.push({functionName:n,arguments:o})}}(f)}}}(document,window.permutive,"f5b3be27-f789-4ef1-8867-37c67da5b361","84c7e805-5ce9-41f4-b988-3529488bab1c",{});
	  permutive.addon('web', {
	    page: {
	      type: stringFromDataLayer('displayType'),
	      language: 'en',
	      tags: stringFromDataLayer('tags').split(","),
	      audience: stringFromDataLayer('audience'),
	      description: 'IBM researchers discover new Magecart scripts suggest planned advertisement injection through Wi-Fi and supply chain attacks.',
	      
	      article: {
	        authors: stringFromDataLayer('author').split(","),
	        description: 'IBM researchers discover new Magecart scripts suggest planned advertisement injection through Wi-Fi and supply chain attacks.',
	        id: stringFromDataLayer('articleId'),
	        isInsiderContent: (stringFromDataLayer('isInsiderContent') == "true"),
	        modifiedAt: "2019-09-25T04:10:06Z",
	        publishedAt: "2019-09-25T04:10:06Z",
	        source: stringFromDataLayer('source'),
	        title: stringFromDataLayer('articleTitle'),
	        type: stringFromDataLayer('articleType'),
	        purchaseIntent: stringFromDataLayer('purchaseIntent')
	      },
	      
	      ads: {
	        adblocker: (adBlockStatus == "true"), //detected further up the page
	        enabled: true
	      },
	      gTax: {
	        primaryIds: [986,576],
	        secondaryIds: [945,67,941,576,951,986]
	      },
	      tax: {
	    	  primaryCategories: stringFromDataLayer('ancestorGoldenCategories').length > 0 ? stringFromDataLayer('ancestorGoldenCategories').split(",").concat(stringFromDataLayer('primaryCategory')) : [stringFromDataLayer('primaryCategory')] ,
	          secondaryCategories: stringFromDataLayer('primaryAncestorCategoryList').length > 0 ? stringFromDataLayer('primaryCategoryList').split(",").concat(stringFromDataLayer('primaryAncestorCategoryList').split(",")) : stringFromDataLayer('primaryCategoryList').split(",")
	      }
	    }
	  });

	  dlJobPosition = dlJobPosition || null;
	  dlIndustry = dlIndustry || null;

	  if (dlJobPosition !== '' || dlIndustry !== '' || stringFromDataLayer('userId') !== '') {
		  window.permutive.track('User', {
			  companySize: null,
			  country: null,
			  id: (stringFromDataLayer('userId') !== "" ? stringFromDataLayer('userId') : null),
			  jobIndustry: (dlIndustry !== "" ? dlIndustry : null),
			  jobPosition: (dlJobPosition !== "" ? dlJobPosition : null),
			  loggedIn: (stringFromDataLayer('insiderSignedIn') == 'true')
			})
	  }
	
	  //product js vars defined in document-head	  
	  if (prodNames !== '' || prodManufacturers !== '' || prodCategories !== '' || prodVendors !== '') {
		  window.permutive.track('Product', {
			  names: stringFromDataLayer('prodNames').split("|"),
			  categories: stringFromDataLayer('prodCategories').split("|"),
			  manufacturers: stringFromDataLayer('prodManufacturers').split("|"),
			  vendors: stringFromDataLayer('prodVendors').split("|")
		});

	  }
		 

</script>

<script>
	$.ajax({
		url: "https://cdn.permutive.com/f5b3be27-f789-4ef1-8867-37c67da5b361-web.js",
	  	dataType: "script",
	  	cache: true, // default is false
	  	async: true // default is true
	});
</script>
	
	
	
	
	
</head>

	<body id="article3440580" class="article cso online">
		
			
			
					
					
						
						
					





















	

		
			
			
				<!-- Begin welcome ad overlay - gpt-overlay position  -->
				
					<div id="superadunit" class="hidden">
						<div class="ad">
							<div class="ad-header">
								<div class="brand-logo"></div>
								<a href="javascript:unhide('superadunit');" id="superstitial-text">Close Ad</a>
							</div>
							<div id="gpt-overlay" class=" ad-container">
								<script type="text/javascript">
								consent.ads.queue.push(function(){
									
										IDG.GPT.addDisplayedAd("gpt-overlay", "true");
										IDG.GPT.displayGoogleTagSlot('gpt-overlay');
									
								});
								</script>
							</div>
						</div>
					</div>
				
				
				<!--  End welcome ad overlay - gpt-overlay position -->
				
			
			
			
			
			
			
		
	
 	
 
 
				
			
		
		











	
		<link rel="stylesheet" href="/www/css/oc-header.css?v=20190924111950" />
		<link rel="stylesheet" href="/www.idge.cso/css/oc-header.css?v=20190924111950" />
		











<header id="banner">
	
		<div class="ad">
			
				
			





















	

		
			
			
			
			
			
			
				<div id="oc_ad_1" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("oc_ad_1", "true");
					$('#oc_ad_1').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: oc_ad_1 - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
  
		</div>
	
	
	
</header>
<script>
$(document).ready(function() {
	var params = {
			def : "blox4.dynamic",
			geo : getLocale(),
			definition : "nav.fixed",
			placement : "Nav Fixed"
			}
		$.get(
			"/napi/tile",
			params,
			function(data, status, xhr) {
				$('#custom_header').html(data);
			},
			"html");
});
	
</script>
<section id="oc-head" class="no-stick-important">
		<div class="oc-head-inner">
			<div class="oc-head-left">
				<a href="/" class="masthead"><span class="logo">cso online</span></a>
				
				
					
					
					
					
					<div class="edition-picker">
						<div class="current-edition" data-edition-name="current"><span id="current-edition">UNITED STATES</span> <i class="fas fa-caret-down"></i></div>
						<ul id="edition-picker-nav">

							
							   
							   
							   
							   
								   
									   <li class="edition-picker-item locale-">
									   		<a data-edition-name="US" data-edition-localeid="0" href="/">United States </a>
									   </li>
								   
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-uk">
									   		<a data-edition-name="uk" data-edition-localeid="2" href="/uk/">United Kingdom </a>
									   </li>
								   
								
							
							   
							   
							   
							   
								   
								   
									   <li class="edition-picker-item locale-in">
									   		<a data-edition-name="in" data-edition-localeid="5" href="/in/">India </a>
									   </li>
								   
								
							

						</ul>
					</div>
				
				
			</div>
			
			<div id="custom_header">
			</div>
			
			<div class="oc-head-right">
				
					
				
				
					<div class="insider-controls">
						<div class="insider-controls-hover">
							<a class="insider edition-link-url" href="/insider/"></a>
							<i class="far fa-user"></i>
						</div>
					            	
					       <div id="insider-welcome">
						           <div id="insider-selector">				                        
						               <div class="stories">
						                        	
						                        	<div class="personalization"><strong>Welcome<span id="person-first-name"></span>!</strong> Here are the latest Insider stories.</div>
						                        	
						                        	











	
	
	
	
	
	
	
	
	
	





























































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3440617/quantum-supremacy-might-be-here-upending-conventional-encryption.html">Quantum supremacy might be here, upending conventional encryption</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3439737/3-devsecops-success-stories.html">3 DevSecOps success stories</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3079230/5-trends-shaking-up-multi-factor-authentication.html">5 trends shaking up multi-factor authentication </a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3440679/how-to-migrate-smartphone-users-to-the-outlook-app-with-intune.html">How to migrate smartphone users to the Outlook app with Intune</a></li>
				
				
			
		
	</ul>




													
													<div class="sign-out-link">
														<a class="more-insider edition-link-url" href="/insider/">More Insider</a>
														<a class="sign-out" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
													</div>
										</div>										
		
						          </div>
						              <div class="signin-register">
						              		
											<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> 
											<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>	
										</div>
										<a class="nav-ip-dropdown" href="https://www.idginsiderpro.com/subscribe">
												<div><b><em>NEW</em></b> FROM IDG</div>
												<span class="dropdownIPLogo"></span>
												<span>Learn More</span>
										</a>
						   </div>
						         
					</div>
					  	
				
				
					<a href="#search" class="search-btn"><i class="fas fa-search"></i></a>
					<div class="search-expand">
						<a href="" class="mega-close ss-delete"></a>		        		
						
					     <div class="gcse-searchbox" >
						     <script>
								(function() {
									var cx = '011881588825642368632:b0mgdf4z90i';
									var gcse = document.createElement('script');
									gcse.type = 'text/javascript';
									gcse.async = true;
									gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
									var s = document.getElementsByTagName('script')[0];
									s.parentNode.insertBefore(gcse, s);
								})();
							</script>
							<gcse:searchbox-only resultsUrl="/search"></gcse:searchbox-only>
							<script>
								$(window).load(function(){
									$('#gsc-i-id1').attr('placeholder','Start Searching');
								})
							</script>	
						</div>
					</div>
				
				
					<a class="mega-btn"></a>
					
				
			</div>
		</div>
</section>











<script>
$(document).ready(function() {
	var paramsmegamenu1 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 1"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu1,
			function(data, status, xhr) {
				$('#megacolumn1').html(data);
				addSlugCode();
			},
			"html");
	var paramsmegamenu2 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 2"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu2,
			function(data, status, xhr) {
				$('#megacolumn2').html(data);
				addSlugCode();
			},
			"html");
	var paramsmegamenu3 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 3"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu3,
			function(data, status, xhr) {
				$('#megacolumn3').html(data);
				addSlugCode();
			},
			"html");
	var paramsmegamenu4 = {
			def : "blox4.dynamic",
			geo : getLocale(),
			placement : "Nav Mega Column 4"
			}
		$.get(
			"/napi/tile",
			paramsmegamenu4,
			function(data, status, xhr) {
				$('#megacolumn4').html(data);
				addSlugCode();
			},
			"html");
});
	
</script>
<nav class="megamenu">
		<div class="megamenu-inner">
			<div class="mega-mobile-nav">
				<a href="#search" class="search-btn"><i class="fas fa-search"></i></a>
				
				
					<div class="mega-insider-icons insider-controls">
					<i class="far fa-user"></i>
					<a class="insider" href="/learn-about-insider/"></a>
					<a class="sign-out-link" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
					<div class="signin-register">
						<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> 
						<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
					</div>
				</div>
				
			</div>
			<a href="" class="mega-close ss-delete"></a>
		
			<div class="mega-logo-content">
			<img class="mega-logo" src="https://alt.idgesg.net/images/furniture/cso/CSO-logo-nameplate.svg" />
			
			<div class="mega-4col">
				<div class="mega-col">
					
						<div class="mega-grp new-insiderpro">
							<div class="mega-hed">NEW <span>Insider</span> PRO
								<a class="ip-learnmore" href="https://www.idginsiderpro.com/subscribe">Learn More</a>
							</div>
						</div>
						<div class="mega-grp latest-insider">					
							<div class="mega-hed ss-directright right">Latest <span>Insider</span></div>
							
							











	
	
	
	
	
	
	
	
	
	





























































	<ul>
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3440019/rich-pii-enables-sophisticated-impersonation-attacks.html">Rich PII enables sophisticated impersonation attacks</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3439539/what-a-security-career-will-look-like-in-five-years.html">What a security career will look like in five years</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3439103/10-signs-youre-being-socially-engineered.html">10 signs you&#039;re being socially engineered</a></li>
				
				
			
		
			
			
				
					
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
						
							
						
						
						
							
						
						
						
					











<li><a  href="/article/3438824/how-to-detect-and-halt-credential-theft-via-windows-wdigest.html">How to detect and halt credential theft via Windows WDigest</a></li>
				
				
			
		
	</ul>




							
							<div id="ip-below-personalize-list" class="mega-grp insider-controls">
								<a class="nav-ip-dropdown" href="https://www.idginsiderpro.com/subscribe">
									<div><b><em>NEW</em></b> FROM IDG</div>
									<span class="dropdownIPLogo"></span>
									<div>Learn More</div>
								</a>
							</div>
						</div>
					
					
						<div id="megacolumn1">
						</div>
				</div>
				<div class="mega-col">
						 <div id="megacolumn2">
						</div>
				</div>
				<div class="mega-col">
					
						
							<div class="mega-grp ip-controls">
								<span class="megamenuIPLogo"></span>
								<div class="mega-hed"><b>NEW FROM IDG</b></div>							
								<span>Subscribe to access expert insight on business technology - in an ad-free environment.. <a href="https://www.idginsiderpro.com/subscribe">Learn more</a> </span>
							</div>
							<div class="mega-grp insider-controls">
								<div class="mega-insider-icons">
									<a class="insider" href="/learn-about-insider/"></a>
									<i class="far fa-user"></i>
								</div>
								<div class="personalization"><strong>Welcome<span id="person-first-name"></span>!</strong> Check out the latest Insider stories <a href="/insider" class="edition-link-url">here.</a></div>
								<a class="sign-out-link" href="javascript://" onclick="IDG.insiderReg.logout()">Sign Out</a>
								<div class="signin-register">
									
									<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-signin')" class="js-open-modal signin" data-modal-id="insider-popup">Sign In</a> 
									<a href="javascript://" onclick="IDG.insiderReg.registerLinkEvent('insider-reg-form-short')" class="js-open-modal register" data-modal-id="insider-popup">Register</a>
								</div>
							</div>
						
						
					
					 <div id="megacolumn3">
					 </div>
				</div>
				<div class="mega-col">
					<div class="mega-grp idg-network">
						<div class="mega-hed ss-directright right">More from the IDG Network</div>
						
							<div id="megacolumn4">
						    </div>
					</div>
				</div>
			</div>
			</div>
			
			<div class="mega-footer">
				    	<ul class="mega-about">
				    		
		            		
							
							
							
								<li><a href="/about/about.html"  >About Us</a> <span class="bar">|</span>
							
								<li><a href="/about/contactus.html"  >Contact</a> <span class="bar">|</span>
							
								<li><a href="/about/privacy.html"  >Privacy Policy</a> <span class="bar">|</span>
							
								<li><a href="/about/cookie-policy.html"  >Cookie Policy</a> <span class="bar">|</span>
							
								<li><a href="/about/member-preferences.html"  >Member Preferences</a> <span class="bar">|</span>
							
								<li><a href="https://www.idg.com/advertise-with-us/cso/" target="_blank" rel="nofollow" >Advertising</a> <span class="bar">|</span>
							
								<li><a href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a> <span class="bar">|</span>
							
								<li><a href="/about/adchoices.html"  >Ad Choices</a> <span class="bar">|</span>
							
								<li><a href="/about/affiliates.html"  >E-commerce Links</a> <span class="bar">|</span>
							
						
		            	</ul>
		            	<ul class="mega-social">
	            			
							<li><a class="social-media-fb" href="https://www.facebook.com/CSOonline" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>				
							
							
								<li><a class="social-media-tw" href="https://twitter.com/csoonline" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
							
							
								<li class="lkndn"><a class="social-media-li" href="http://www.linkedin.com/company/csoonline" rel="nofollow" target="_blank"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
							
							
							
	            		</ul>
		            
			            <script>
			            	if (facebookUrl !== null && facebookUrl !== "") {
				            	document.querySelector(".social-media-fb").setAttribute("href", facebookUrl);
			            	}
			            	if (twitterUrl !== null && twitterUrl !== "") {
				            	document.querySelector(".social-media-tw").setAttribute("href", twitterUrl);
			            	}
			            	if (youTubeUrl !== null && youTubeUrl !== "") {
			            		if (document.querySelector(".social-media-yt") !== null) {
				            		document.querySelector(".social-media-yt").setAttribute("href", youTubeUrl);
			            		} else {
			            			if (typeof countryCode !== 'undefined' && countryCode === "in") {
			            				youTubeUrl = "";
			            			}
			            			$( "<li class='ytb'><a class='social-media-yt' href='"+youTubeUrl+"' rel='nofollow' target='_blank'><i class='ss-icon ss-social-circle brand ss-youtube'></i></a></li>" ).insertAfter("li.lkndn");
			            		}
			            	}
			            	if (document.querySelector(".social-media-li") !== null) {
				            	if (typeof linkedInUrl !== "undefined" && linkedInUrl !== null && linkedInUrl !== "") {
					            	document.querySelector(".social-media-li").setAttribute("href", linkedInUrl);
				            	} else {
				            		$("li.lkndn").hide();
				            	}
			            	}
			            </script>
					

		</div>
	</div>
	<div class="mega-submenu">
			<a href="" class="mega-mobile-nav ss-left"></a>
			<a href="" class="mega-close ss-delete"></a>
			<div class="submenu-contents"></div>
	</div>
</nav>



	<div id="insider-popup" class="modal-box ">
	
		<div class="insider-modal-wrapper">
	  
			<div class="modal-header-title">
				<div class="modal-banner-insider"><span class="insider"></span></div>
		    	<div class="modal-close close">×</div>
		  	</div>
		  	
		  	<div class="modal-body">
		  		
		  			
						<script>
$(document).ready(function(){
	$('a[data-link]').click(function() {
		
		  //get this link's dataLink value
		  var dataLink = $(this).attr('data-link');

		  //select the div with the same value
		  var toKeep = 'div[data-link="'+dataLink+'"]';
	
		  //select data-link divs that are not the above div
		  $('div[data-link]').not(toKeep).hide();
		  
		  if($(this).hasClass('link-transition')){
			  $(toKeep).fadeIn(800);
		  } else {
			  $(toKeep).show();
		  }
	
		  //prevent location change
		  return false;
	});
	

});
</script>

					
					
				
		  	</div>
		  	
		  	<div class="modal-footer">
		    	<div class="modal-close close-btn">Close</div>
		  	</div>
		</div>
	  	
	</div>

	<script>
		$(document).ready(function(){

			var appendthis =  ("<div class='modal-overlay modal-close'></div>");
			if($thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').css({
					//top: ($(window).height() - $(".modal-box").outerHeight()) / 2,
					top: 10,
					left: 0
				});
			}
			
			
			if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
				$('.modal-box').height($(document).height());
				$('.modal-box').css('top','0');
			}
			
			var userAg = navigator.userAgent;

			$('a[data-modal-id]').click(function(e) {
				e.preventDefault();
				$('body').append(appendthis);
				$('.modal-overlay').fadeTo(500, 0.9);
				$('.modal-overlay').height($(document).height());
				var modalBox = $(this).attr('data-modal-id');
				
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$('#'+modalBox).fadeIn($(this).data()); // triggered by something other than onclick of link such as scroll to point in window
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('#'+modalBox).toggle('slide', {direction: 'up'}, 800);
					//} else {
				   // 	$('#'+modalBox).toggle('slide', {direction: 'left'}, 600);
					//}
				}

				if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
					$("html, body").animate({
			            scrollTop: 0
			        }, 700);
			        
			        
			        $('a.btn.continue-on').click(function() {
			        	$('html, body').animate({
			        		scrollTop: 0
			        	}, 500);
			        });
			        
			        return false;
			        
				}
				if (navigator.userAgent.match(/(iPad)/)) {
					$("html, body").animate({
			            scrollTop: 0
			        }, 500);
				}
			});
		  
		  
			$(".modal-close, .modal-overlay").click(function() {
				$('.select2-drop').css('display','none');
				$(".modal-overlay").fadeOut(500, function() {
					$(".modal-overlay").remove();
				});
				if ($(".modal-box").hasClass('triggered') || (userAg.indexOf("Firefox")!=-1)) {
					$(".modal-box").fadeOut(500);
				} else {
					// IDGMPM-16177
					//if(!$thm.deviceWidthAtLeast($thm.deviceBreakpoints.tablet)){
						$('.modal-box').toggle('slide', {direction: 'up'}, 800);
					//} else {
					//	$('.modal-box').toggle('slide', {direction: 'left'}, 600);
					//}
				}
			});
		
		});
	</script>


<script>
var relatedTop;
</script>

		
	<link rel="stylesheet" href="/www/css/content-ribbon.css?v=20190924111950" />

	











<!-- Related Content -->




	<div class="related-content-wrapper">
		<div class="sector apart">
			
	    	<ul class="ribbon-row">
	    		    	
		    	

		    		
						
						
						
					














<li class="item-0 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3400381/what-is-magecart-how-this-hacker-group-steals-payment-card-data.html">What is Magecart? How this hacker group steals payment card data</a></div>
	</div>
</li>


	<li class="ribbon-col ribbon-hed">
		<div class="item">
			<div class="title">
				RELATED STORIES
			</div>
		</div>
	</li>



					
		    	

		    		
						
						
						
					














<li class="item-1 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3253572/what-is-cryptojacking-how-to-prevent-detect-and-recover-from-it.html">What is cryptojacking? How to prevent, detect, and recover from it</a></div>
	</div>
</li>




	<li class="ribbon-col nativo-ribbon-item">
		<div class="title">
			<span class="item-eyebrow">SPONSORED BY <i>Advertiser Name Here</i></span>
			<a href="">Sponsored item title goes here as designed</a>
		</div>	
	</li>

					
		    	

		    		
						
						
						
					














<li class="item-2 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3253899/the-best-new-windows-10-security-features.html">Best new Windows 10 security features: Windows Sandbox, more update options</a></div>
	</div>
</li>




					
		    	

		    		
						
						
						
					














<li class="item-3 ribbon-col">
	<div class="item">
		
		<div class="title"><a  href="/article/3378016/magecart-payment-card-skimmer-gang-returns-stronger-than-ever.html">Magecart payment card skimmer gang returns stronger than ever</a></div>
	</div>
</li>




					
		    	
		    	
		    	
					
					
						
						
						
							
							
							
							
							
							
							
							
							
							
						






























































					
				
		    </ul>
		</div>
	</div>

	<script>
	// Remove related content ribbon if device is less than tablet size (768px)
	if ($thm.deviceWidthLessThan($thm.deviceBreakpoints.tablet)) {
		$('.related-content-wrapper').remove();
	}

	</script>
	



<script>
var coreEdition = '';
var coreEditionAbbr = 'US';
var coreEditionDescription = 'United States';
//debugger;
$(document).ready(function() {
	$('.edition-picker').css("display",'inline-block');
	//reader selects edition from picker
	$("li.edition-picker-item a").on('click', function() {
		//debugger;
		//console.log("====edition-picker onclick - localeId from slug = " +  getIdFromSlug[$(this).attr("data-edition-name")]);
		var localeSlug = $(this).attr("data-edition-name");
		var selectedLocaleId = $(this).attr("data-edition-localeid");
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'editionChange',
			'eventCategory':'Edition Change',
			'eventAction':localeSlug,
			'eventLabel':''
		});
		setSelectedLocale(selectedLocaleId); // save selection in cookie
		
	});
	var getDescFromId = getApolloLocaleDescMap();
	var localeDesc = "";
	//debugger;
	// if selectedLocale cookie exists, get locale
	if (typeof  getSelectedLocale() !== 'undefined' && getSelectedLocale() === getLocale()) { // get locale from cookie if available otherwise, use another locale source (from geolocation, url slug, etc.)
	 	countryCode = getSlugFromId[getSelectedLocale()];
	 	localeDesc = getDescFromId[getSelectedLocale()];
	} else {
		countryCode = getSlugFromId[getLocale()];
		localeDesc = getDescFromId[getLocale()];
	}
	// if countryCode is empty string at this point, it means getLocale() has localeId as 0 which is global locale.
	if (!countryCode) {
		countryCode = coreEditionAbbr; // country code for default global depends on brand (US for cio.com)
		localeDesc = coreEditionDescription;
	}

	// set current edition in header
	$("#current-edition").html(localeDesc.toUpperCase());
});
</script>

<script>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</script>

	
	



		
		













<div id="page-wrapper" class="page-wrapper">
	
	













<div id="skinAdTarget"></div>


			
		











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	





	
	
 	


	
	<section role="main">
	
		
		
		

		<article itemscope itemtype="http://schema.org/NewsArticle"  >

		















<!-- Events Header -->

 
 
	
		
		
		
		
		
					    			
		
	
	
	
	
	

 
 
 
 
  
  
 
 












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	


<!-- //end Events Header -->


	
	
	
	
	
	
		
	



	
		
	
	
	
		

































<script src="/www/js/date-time-moments.js"></script>


	
		<script>
		$(document).ready(function() {
			var fullDate = "2019-09-25T04:10-0700";
			var timeDate = "";
			var dateFormat = "MMM D, YYYY h:mm a z";
			var dateFormatIntl = "D MMMM YYYY H:mm z";
			
			if ( document.getElementById("current-edition").textContent !== "UNITED STATES" ) {
				if ( document.getElementById("current-edition").textContent === "INDIA" ) {
					timeDate = moment(fullDate).tz('Asia/Calcutta').format(dateFormatIntl); // intl format eg: 10 AUGUST 2019 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "UNITED KINGDOM" ) {
					timeDate = moment(fullDate).tz('Europe/London').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "ASEAN" ) {
					timeDate = moment(fullDate).tz('Asia/Singapore').format('D MMMM YYYY H:mm') + " SGT"; // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "MIDDLE EAST" ) {
					timeDate = moment(fullDate).tz('Asia/Riyadh').format('D MMMM YYYY H:mm') + " AST"; // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "AFRICA" ) {
					timeDate = moment(fullDate).tz('Africa/Johannesburg').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "AUSTRALIA" ) {
					timeDate = moment(fullDate).tz('Australia/Sydney').format(dateFormatIntl); // 24 hours format no am/pm
				} else if ( document.getElementById("current-edition").textContent === "NEW ZEALAND" ) {
					timeDate = moment(fullDate).tz('Pacific/Auckland').format(dateFormatIntl); // 24 hours format no am/pm
				} else {
					timeDate = moment(fullDate).tz(Intl.DateTimeFormat().resolvedOptions().timeZone).format(dateFormatIntl); // 24 hours format no am/pm
				}
				document.querySelector(".format-date").textContent = timeDate;
			} else { // edition = UNITED STATES
				timeDate = moment(fullDate).tz('America/Los_Angeles').format(dateFormat); // US format eg: AUGUST 10, 2019 12 hour format
				document.querySelector(".format-date").textContent = timeDate;
			}
		});
		</script>
	
	
















	<style>
		nav.breadcrumbs { visibility: hidden; }
	</style>
	<script type="text/javascript">
	$(document).ready(function() {
		if ( document.getElementById("current-edition").textContent !== "UNITED STATES" ) {
			
	        var Obj = { 
	        	Centers: "Centre",
	        	Center: "Centre",
                Consumerization: "Consumerisation", 
                Fiber: "Fibre", 
                Internationalization: "Internationalisation",
                Licensing: "Licencing",
                Optimization: "Optimisation",
                Theater: "Theatre",
                Virtualization: "Virtualisation",
                Visualization: "Visualisation" 
            };
			
			if ( $("span").hasClass("primary-cat-name2") || $("span").hasClass("article-primary-cat") || $("span").hasClass("primary-cat-name") ) {
				var primaryCatName = "";
				var pluralCategory = document.querySelectorAll(".primary-cat-name2, .article-primary-cat, .primary-cat-name");
				
				pluralCategory = [].slice.call(pluralCategory);
				
				pluralCategory.forEach(function(element) {			
					primaryCatName = element.textContent.replace(/Centers|Center|Consumerization|Fiber|Internationalization|Licensing|Optimization|Theater|Virtualization|Visualization/, function(matched) { 
						return Obj[matched];
		            });			
					$(element).text(primaryCatName);
				});
			}
		} 
		$('nav.breadcrumbs').css('visibility','visible');
	});
	</script>




	
			















<header class='cat'>

	
	
	
	
	
	
	
	
	
	
	
	<nav class="breadcrumbs horiz">
		<ul itemscope itemtype="http://data-vocabulary.org/Breadcrumb">
			<li><a class="edition-link-url" href="/" itemprop="url"><span itemprop="title">Home</span></a></li>
			
				
				
					<li><a class="edition-link-url primary-cat-url" href="/category/compliance/" itemprop="url"><span class="primary-cat-name" itemprop="title">Compliance</span></a></li>
				
				
					<li><a class="edition-link-url" href="/category/fraud/" itemprop="url"><span class="article-primary-cat" itemprop="title">Fraud</span></a></li>
				
			
		</ul>
	</nav>
	
	
	
	
	
	
	
	
	
	
		
		
			<div class="category"><a class="edition-link-url" href="/news" itemprop="genre">News</a></div>
		
	
	

	<h1 itemprop="headline">Magecart web skimming group targets public hotspots and mobile users</h1>
	
	
	
	
		<section class="deck viewability">
			<h3 itemprop="description">IBM researchers discover new Magecart scripts suggest planned advertisement injection through Wi-Fi and supply chain attacks.</h3>
		</section>
	
	
	
	
			<div class="cat-social">
				
					
				
















 



	

				

	
	
		
		
	



	
	


	


<div id="sharer" class="cat sidecar show">
<ul id="share-tool" class="expand">


	<li class="sosh">
		<a data-socialsite="Twitter" class="twit-hand" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.csoonline.com%2Farticle%2F3440580%2Fmagecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html&via=csoonline&text=Magecart+web+skimming+group+targets+public+hotspots+and+mobile+users" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/twitter.svg" />
		</a>
	</li>
	
		<li class="sosh">
			<a data-socialsite="Facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.csoonline.com%2Farticle%2F3440580%2Fmagecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/facebook.svg" />
			</a>
		</li>
	
	<li class="sosh">
		<a data-socialsite="Linkedin" href="http://www.linkedin.com/shareArticle?url=https%3A%2F%2Fwww.csoonline.com%2Farticle%2F3440580%2Fmagecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html&title=Magecart+web+skimming+group+targets+public+hotspots+and+mobile+users" target="_blank">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/linkedin.svg" />
		</a>
	</li>
	
		<li class="sosh hide">
			<a data-socialsite="Reddit" href="http://reddit.com/submit?url=https%3A%2F%2Fwww.csoonline.com%2Farticle%2F3440580%2Fmagecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html&title=Magecart+web+skimming+group+targets+public+hotspots+and+mobile+users" target="_blank">
				<img class="sidecar-icon" src="//idge.staticworld.net/images/reddit.svg" />
			</a>
		</li>
	
	<li class="sosh hide">
		<a href="mailto:?Subject=Magecart web skimming group targets public hotspots and mobile users&Body=Check%20out%20this%20article%20from%20CSO Online%3A%20https%3A%2F%2Fwww.csoonline.com%2Farticle%2F3440580%2Fmagecart-web-skimming-group-targets-public-hotspots-and-mobile-users.html" target="_blank" rel="nofollow" id="email-icon">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/mail.svg" />	
		</a>
	</li>
	<li class="sosh hide print">
		<a href="javascript:window.print();">
			<img class="sidecar-icon" src="//idge.staticworld.net/images/print.svg" />
		</a>
	</li>
	<li class="more">
		<div class="more-icon" onclick="document.getElementById('share-tool').className = 'expand';"></div>
	</li>




</ul>
</div>

<script type="text/javascript">
$(document).ready(function() {
	if (twitterHandle != "") {
		$("a[href*=via]").attr("href", function(_, href) {
			  return href.replace(/via=csoonline/, "via="+twitterHandle);
		});
	}
	
	//Add Social Share Event Tag in GTM - IDGMPM-17271
	$("a[data-socialsite]").click(function() {
		var dataLayer = window.dataLayer = window.dataLayer || [];
		dataLayer.push({
			'event': 'socialShare', 
		  	'eventCategory': 'Social Share',
		  	'eventAction': $(this).attr("data-socialsite"), 
		  	'eventLabel': window.document.title
		});
		
	});
});
</script>

<script type="text/javascript">
var isValidEmailAddress = isValidEmailAddress || function(emailAddress) {
    var pattern = new RegExp(/^[+a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,5}$/i);
    return pattern.test(emailAddress);
};
function encodeQueryData(params) {
	var ret = [];
	for (var paramKey in params) {
		ret.push(encodeURIComponent(paramKey) + "=" + encodeURIComponent(params[paramKey]));
	}
	return ret.join("&");
}
</script>

			</div>
	
	
	

	
		
			
				
				<div class="cat byline vcard author with-image">		
					<div class="byline-wrapper">
						<p class="name" itemscope itemtype="http://schema.org/Person" itemprop="author">
							
						
							
							
							
							
						
















<a href="/author/Lucian-Constantin/" rel="author" title="Lucian Constantin"><img  class="bylineImage  imgId100258922 " src="https://images.techhive.com/images/article/2014/04/lucian_constantin-100258922-byline.jpg" width="34" width="34" alt="Lucian Constantin" itemprop="image" /></a>

						
							
								
							
















<span class="by">By </span><span class="fn" itemprop="name"><a rel="author" itemprop="url" href="/author/Lucian-Constantin/"><span itemprop="name">Lucian Constantin</span></a></span>
						</p>
						<p class="dateline">
						
							CSO Senior Writer, 
								
									
								












<span itemprop="publisher" itemscope itemtype="http://schema.org/Organization"><span class="publisher" itemprop="name">CSO</span><meta itemprop="logo" content="https://idge.staticworld.net/cso/CSO_logo_300x300.png"/></span> <span class="divider break">|</span>
							
	
							<span class="pub-date" class='break-date' itemprop="datePublished" 
							    content="2019-09-25T04:10-0700"><span class="format-date"></span>
								
							</span>
						</p>
					</div>
				</div>
			
		
	
	
		
	
	
		
			<div class="ad viewability" id="viewabilityAdContainer">
				<div id="viewabilityAdUnit">
					
						
					





















	

		
			
			
			
			
			
			
				<div id="topleaderboard" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("topleaderboard", "true");
					$('#topleaderboard').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topleaderboard - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
				</div>
			</div>
			
				
				<script src="/www/js/ads/stickyLb.js"></script>
				<script>
					(function(){
						var parallaxArgs = {
							topNavEl: 'oc-head',
							topNavIsSticky: true,
							leaderboadrdId: 'topleaderboard', 
							adContainer: 'viewabilityAdContainer',
							adUnit: 'viewabilityAdUnit',
							viewabilityTime: 10000
						}
						parallaxLb(parallaxArgs);
					})();
					
				</script>
			
		
	
	
	
	
	
</header>




	
	
	
	
		<div class="lede-container">
			
			
			
				
				
					
		                
		                	
		                	
		                
		                
						
						
						
					
					
					
					
					<figure itemprop="image" itemscope itemtype="http://schema.org/ImageObject" class="hero-img">
						<meta itemprop="representativeOfPage" content="1" />
						<meta itemprop="height" content="800" />
						<meta itemprop="width" content="1200" />
			    		
			    		<img data-original="https://images.idgesg.net/images/article/2019/06/online-shopping-cart_magecart_hackers_shopping-online-100798500-large.jpg" class="lazy" loading="lazy" alt="online shopping cart magecart hackers shopping online" itemprop="contentUrl" itemprop="url" />
			    		
			    		<figcaption>
			    			
			    			
			    				<span class="credit" itemprop="copyrightHolder">
			    					
					    				
					    				MicroStockHub / Getty Images
				    				
		
					    			
					    				
					    				
					    				
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
										  	
										
					    				
					    				
										
									
							
								</span>
			    			
							
			    		</figcaption>
					</figure>
					
		
				
				
			
		</div>
	




<section class="epo cat-narrow" id="drr-top-ad">

	
	
	
	
	
	
		<div class="ad top-ad">
	
		
		
			
				
					
					
						
					
				
				
				
			





















	

		
			
			
			
			
			
			
				<div id="topimu" class="adunit ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				if($(window).width() >= 930) {
					IDG.GPT.addDisplayedAd("topimu", "true");
					$('#topimu').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: topimu - [971 1115]");
                    
				}
				});
				</script>
			
		
	
 	
 
 
		
	
</div>
	
	
	
	
	
	
	
	
	
</section>













<script src="/www/js/deal-modules.js"></script>

		
		



		<section class="bodee">

			
				
				
					












	
		





















<style>
	#drr-container figure.large.video {
		border-bottom: 0 none;
	}
	figure#page-lede.thm-gallery.rr-gallery-vid #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 300px !important;
		height: 169px !important;
		transition: all 0.5s ease;
	}
	figure#page-lede.thm-gallery #bcplayer-gallery #bcplayer-gallery_ad > div {
		width: 100%;
		height: 100%;
		transition: all 0.5s ease;
	}
</style>
<style>
.jwplayer.jw-state-paused .jw-display {
	display: table !important;
	padding: 0;
}
.jwplayer .jw-display-icon-container {
    float: none;
    padding: 0;
    margin: 0;
}
.jw-flag-small-player .jw-display {
	padding-top: 0px;
}
.jwplayer .jw-display-icon-container .jw-icon-rewind {
	visibility: hidden;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play path,
.jw-state-idle .jw-svg-icon-play path,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay path,
.jw-state-complete .jw-svg-icon-replay path {    
    display: none;
}
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    background-size: contain;
    background-repeat: no-repeat;
    background-color: transparent;
    background-image: url(//idge.staticworld.net/idgtv/btn-play-default.svg);
    background-position: center center;
    bottom: 0;
    border-radius: 0;
    box-shadow: none;
    left: 0;
    margin: auto;
    right: 0;
    top: 0;
}
.jwplayer .jw-display-icon-container .jw-icon,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.jw-state-idle .jw-svg-icon-play,
.jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.jw-state-complete .jw-svg-icon-replay {
    height: 81px;
    width: 78px;
}
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container .jw-icon,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jw-state-idle .jw-svg-icon-play,
.thm-gallery.rr-gallery-vid .jwplayer .jw-display-icon-container  .jw-icon-display .jw-svg-icon-replay,
.thm-gallery.rr-gallery-vid .jw-state-complete .jw-svg-icon-replay  {
	height: 65px;
    width: 62px;
}
</style>


	



	
	
	
	
		<div class="ad placement">
			
				
			





















	

		
			
			
			
				<script>
					var supLocaleEd = false;
					if (typeof countryCode !== 'undefined' && countryCode !== "" && countryCode === 'in') {
						supLocaleEd = true;
					}
				</script>
				<!--  Begin inread -->
				<div id="inread" class=" ad-container">					
				</div>
				
				<script>
					if (supLocaleEd === true) {
						$("div#inread").remove();
					} else {
						consent.ads.queue.push(function(){
							IDG.GPT.addDisplayedAd("inread", "true");
							IDG.GPT.displayGoogleTagSlot('inread');
						});
					}
				</script>
				
				<!--  End inread -->	
			
			
			
			
		
	
 	
 
 
		</div>
	
	
	
	
	
	
	
	
		
		
			
			
			<script>
				var dataLayer = window.dataLayer = window.dataLayer || [];
				dataLayer.push({
					'event': 'loadTopCollectionModule'
					});
			</script>
			
		
	
	
	
	
	













<script type="text/javascript">

$(document).ready(function() {
	$('.articleBloxAd').filter( ":visible" ).each(function(index, item) {
		var id = $(item).attr('id');
		var divClass = $(item).attr('class');
		var adString = IDG.GPT.getLazyAdCode();
		$(item).replaceWith("<div id=\"" + id + "\" class=\"lazyload_blox_ad " + divClass + "\">" + adString + "</div>");
	});
	try {
		$("div.lazyload_blox_ad").lazyLoadAd({
	        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
	        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
	        onLoad       : false,       // Callback function on call ad loading
	        onComplete   : false,       // Callback function when load is loaded
	        timeout      : 1500,        // Timeout ad load
	        debug        : false,       // For debug use : draw colors border depends on load status
	        xray         : false        // For debug use : display a complete page view with ad placements
		}) ;
	}
	catch (exception){
		console.log("error loading lazyload_ad " + exception);
	}
});

</script>
			
	
		
	
			
			













<style>
@media only screen and (min-width: 60.625em) {
	article .apart.ad.not-lazy {
		margin-left: 0;
		float: right;
	}
}
/* this spaces the ads in the right rail */
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow #imu2 {
		margin-top: 390px; /*originally 354px*/
	}
	.topDeals.topper {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
@media only screen and ( min-width: 48em ) and ( max-width: 58.063em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 0;
	}
}
@media only screen and ( min-width: 60.625em ) {
	article #drr-top-ad.epo.cat-narrow div[id^=imu] {
		margin-top: 390px;
	}
}
</style>


<script type="text/javascript">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</script>
			
			
	
	
	
	
	
		
		
			
		
	
	
	
	
	
		
			
				
				
				
					
				
				
			
		
		
	
	
		
		
			<div id="drr-container" class='cat ' itemprop="articleBody">
		
		
		
		
	
		
			
			
				<p>One of the web skimming groups that operate under the Magecart umbrella has been testing the injection of payment card stealing code into websites through commercial routers like those used in hotels and airports. The group has also targeted an open-source JavaScript library called Swiper that is used by mobile websites and apps.</p><aside class="fakesidebar">
<p>[ Get inside the mind of a hacker, <a href="https://www.csoonline.com/article/3267988/hacking/what-hackers-do-their-motivations-and-their-malware.html">learn their motives and their malware</a>. | <a href="http://www.csoonline.com/newsletters/signup.html">Sign up for CSO newsletters</a>! ]</p>
</aside><p>Security researchers from IBM’s X-Force Incident Response and Intelligence Services team have found what appear to be test skimming scripts developed earlier this year by one of the most prolific of the dozen or so groups tracked by the security industry as Magecart. These groups have compromised thousands of websites to date and have injected malicious code designed to steal payment details into their checkout pages.</p><p>Some of the Magecart victims have included high-profile brands such as British Airways, TicketMaster and Newegg. The groups <a href="https://www.csoonline.com/article/3378016/magecart-payment-card-skimmer-gang-returns-stronger-than-ever.html" rel="noopener" target="_blank">are known for using a variety of techniques</a> to both infect websites and to hide their malicious code injected into pages, including the compromise of legitimate third-party services that already have Magecart scripts loaded into websites.</p><p>The X-Force investigation started with a couple of scripts found on VirusTotal, an online file and URL scanning service and aggregator of malware intelligence from vendors and user submissions. The scripts showed strong similarities to malicious code associated in the past with a group tracked as Magecart Group 5 (MG5).</p><p>Based on those initial files, the researchers tracked down a total of 17 scripts uploaded since April by the same user from Russia. Many of the scripts are similar but have modifications designed to bypass antivirus detection, suggesting their creator was using VirtusTotal to test the effectiveness of his changes.</p><h2>Advertisement injection through Wi-Fi</h2><p>One of the skimmer scripts, called test4.html, references and is based on a script called advnads20.js that was associated in 2012 with rogue advertisement injection through Wi-Fi hotspots in hotels. The script contains code to interact with a commercial grade Layer 7 router.</p><aside class="nativo-promo nativo-promo-1 smartphone" id=""> </aside><p>“Having access to a large number of captive users with very high turnover, like in the case of airports or hotels, is a lucrative concept for attackers looking to compromise payment data,” the X-Force team said <a href="https://www.ibm.com/downloads/cas/O3W1LZAZ?cm_mc_uid=47694554259615694110432&amp;cm_mc_sid_50200000=63571171569411043290" rel="noopener nofollow" target="_blank">in its report</a>. “We believe that MG5 aims to find and infect web resources loaded by L7 routers with its malicious code, and possibly also inject malicious ads that captive users have to click on to eventually connect to the internet.”</p><aside id="fsb-2599" class="fakesidebar fakesidebar-auto fakesidebar-sponsored"><strong>[ <a href="https://pluralsight.pxf.io/c/321564/424552/7490?u=https%3A%2F%2Fwww.pluralsight.com%2Fpaths%2Fcertified-information-systems-security-professional-cisspr" rel="nofollow">Prepare to become a Certified Information Security Systems Professional with this comprehensive online course from PluralSight. Now offering a 10-day free trial!</a> ] </strong></aside><p>The malicious script is designed to collect information from all web forms, not just checkout pages. That’s because the compromise of Wi-Fi routers allows attackers to steal data when users are initially prompted to register and pay for using the internet, but also later, by automatically injecting skimming scripts into all websites accessed by users through those devices. Unlike Magecart attacks that are tailored for one website or brand, this is a catch-all type of compromise.</p><aside class="nativo-promo nativo-promo-1 tablet desktop" id=""> </aside><h2>Supply chain attack a possible intent</h2><p>Another identified file, called test3.html, is an injector script designed to load resources from external URLs into a compromised web page. One of the URLs it references points to a legitimate JavaScript library called Swiper, suggesting the intention to launch a supply chain attack through this script.</p><p>Swiper is a popular open-source library that can make websites designed for desktop-based access compatible with browsing from mobile devices. It can also be integrated into native and web-based mobile apps. Based on statistics, it’s used by over 280,000 websites, most of them from the US and China.</p><p>The targeting of third-party scripts that are loaded into legitimate websites is consistent with <a href="https://cdn.riskiq.com/wp-content/uploads/2018/11/RiskIQ-Flashpoint-Inside-MageCart-Report.pdf" rel="noopener nofollow" target="_blank">MG5’s modus operandi observed so far</a>. For example, TicketMaster, one of MG5’s high-profile victims, was compromised through SociaPlus, a web analytics service. The group also compromised SAS Net Reviews, a verified reviews service used by e-commerce sites.</p><p>“This scenario involving the technology supply chain, infecting Swiper in this case, is consistent with MG5’s historical methods of targeting third-party platforms that would give the group a broad reach into numerous victims with a single compromise,” the X-Force researchers said.</p><aside class="nativo-promo nativo-promo-2 tablet desktop smartphone" id=""> </aside><p>The X-Force team’s advice for website owners is to avoid third-party code with known vulnerabilities, to use extension blacklists and to implement code and file integrity checks, especially for externally loaded JavaScript files. To protect their users from man-in-the-middle injections, like those performed through compromised routers, site operators can deploy strong content security policies (CSP) to prevent browsers from loading rogue resources.</p><aside class="fakesidebar">
<p><strong>More on malware</strong></p>
<ul>
<li><a href="https://www.csoonline.com/article/3295877/malware/what-is-malware-viruses-worms-trojans-and-beyond.html">What is malware? Viruses, worms, trojans, and beyond</a></li>
<li><a href="https://www.csoonline.com/article/2883958/malware/malware-detection-in-9-easy-steps.html">Malware detection in 9 easy steps</a></li>
<li><a href="https://www.csoonline.com/article/3267572/encryption/how-to-detect-and-prevent-crypto-mining-malware.html">How to detect and prevent crypto mining malware</a></li>
<li><a href="https://www.csoonline.com/article/2615925/security/security-your-quick-guide-to-malware-types.html">8 types of malware and how to recognize them</a></li>
<li><a href="https://www.csoonline.com/article/2894520/data-protection/are-you-infected-with-malware-check-windows-registry-keys.html">Infected with malware? Check your Windows registry</a></li>
</ul>
</aside>
			
		
		
	
		
		
			
		
		
		
		
			
			
			
			










<div class="end-note">
	
		
	











	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #2004 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		
















	
		
		
			<div id="" class="blx blxParticleendnote blxM2004  blox4_html  blxC30910"><aside>
  <strong>Next read this</strong> 
  <ul>
    
    <li><a href="https://www.csoonline.com/article/3337245/the-new-cisos-playbook-5-rules-to-follow.html">The new CISO's playbook: 5 rules to follow</a></li>
    
    <li><a href="https://www.csoonline.com/article/3262972/7-hot-cyber-security-trends-and-4-going-cold.html">7 hot cybersecurity trends (and 4 going cold)</a></li>
    
    <li><a href="https://www.csoonline.com/article/3116884/top-cyber-security-certifications-who-theyre-for-what-they-cost-and-which-you-need.html">Top cyber security certifications: Who they're for, what they cost, and which you need</a></li>
    
    <li><a href="https://www.csoonline.com/article/3306757/the-best-password-advice-right-now.html">The best password advice right now (Hint: It's not the NIST guidelines)</a></li>
    
    <li><a href="https://www.csoonline.com/article/3340819/7-cheap-or-free-cybersecurity-training-resources.html">8 cheap or free cybersecurity training resources</a></li>
    
    <li><a href="https://www.csoonline.com/article/3276008/24-best-free-security-tools.html">24 best free security tools</a></li>
    
    <li><a href="https://www.csoonline.com/article/3340819/7-cheap-or-free-cybersecurity-training-resources.html">8 cheap or free cybersecurity training resources</a></li>
    
    <li><a href="https://www.csoonline.com/article/3116884/top-cyber-security-certifications-who-theyre-for-what-they-cost-and-which-you-need.html">Top cyber security certifications: Who they're for, what they cost, and which you need</a></li>
    <li><a href="https://www.csoonline.com/article/3367797/12-tips-for-effectively-presenting-cybersecurity-to-the-board.html">12 tips for effectively presenting cybersecurity to the board
</a></li>
   
    </ul>
</aside>    



                     </div>
		
	

	


</div>
		
		
	</div>
	
	
	
	
	
	<script>
$("a[data-product-id]").on('click',function(e){
	var e = e || window.event;
	var dataLayer = window.dataLayer = window.dataLayer || [];
	var prodName = $(this).attr("data-product-name");
	prodName = prodName.replace("\\'","'"); // to counter the effects of over-escaping
	
	if ( $(this).parents('.slideshow').length > 0 ) {
		var productLinkPosition = "Slideshow";
	} else if ( $(this).parents('.emo-sb').length > 0 ) {
		var productLinkPosition = "Product Sidebar";
	} else if ( $(this).parents('.at-a-glance.top').length > 0 ) {
		var productLinkPosition = "AAG Top";
	} else if ( $(this).parents('.at-a-glance').length > 0 ) {
		var productLinkPosition = "AAG Bottom";
	} else if ( $(this).parents('.quick-hits.medium').length > 0 ) {
		var productLinkPosition = "Quick Hit Medium";
	} else if ( $(this).parents('.quick-hits').length > 0 ) {
		var productLinkPosition = "Quick Hit Full";
	} else if ( $(this).parents('.product-chart').length > 0 ) {
		var productLinkPosition = "Product Chart";
	} else if ( $(this).parents('.emo-list').length > 0 ) {
		var productLinkPosition = "Product List";
	} else {
		var productLinkPosition = "Body Text";
	}
	
	dataLayer.push({
		'event': 'affiliateLink', 
	  	'eventCategory': 'Affiliate Link', // Hardcoded, not dynamic
	  	'eventAction': 'Click', // Hardcoded, not dynamic
	  	'eventLabel': ''+e.target+'', // The URL the affiliate link leads to
	  	'productVendor': $(this).attr("data-bkvndr"), // The vendor of the product
	  	'productManufacturer': $(this).attr("data-bkmfr"), // The manufacturer of the product
	  	'productName': prodName, // The name of the product
	  	'productId': $(this).attr("data-product-id"), // The ID of the product
	  	'productLinkPosition': productLinkPosition // location of product link (Product Sidebar, Product Chart, etc.)
	});
	
});
</script>
	
	
		<script>
$("#drr-container a:not('[data-product-id]')").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickParentsUntilDrr = $clickEl.parentsUntil("#drr-container");
	var clickText = $clickEl.text().trim();
	var linkLocation;
	var linkType;
	var regex = new RegExp("cio.com|csoonline.com|computerworld.com|itnews.com|itworld.com|infoworld.com|networkworld.com|javaworld.com|techconnect.com|techhive.com|macworld.com|pcworld.com|greenbot.com|gamestar.com", "i");
	
	if (clickParentsUntilDrr.hasClass("fakesidebar")) {
		linkLocation = "FSB";
	}
	else if (clickParentsUntilDrr.hasClass("end-note")) {
     	 linkLocation = "End Note";
   }
	else {
		linkLocation = "Body";
	}
	
	if (regex.test(clickUrl)) {
	      linkType = "Internal";
	    }
	else {
		linkType = "External";
	}
		
	
	dataLayer.push({
		'event': 'editBodyLink', 
	  	'eventCategory': 'Editorial Body Links',
	  	'eventAction': linkType,
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	<script>
$("#drr-top-ad .related-promo-wrapper .title > a").on('click',function(e){
	var dataLayer = window.dataLayer = window.dataLayer || [];
	
	var $clickEl = $(this);
	var clickUrl = $clickEl.attr("href");
	var clickText = $clickEl.text().trim();
	var linkLocation = "Promo";		
	
	dataLayer.push({
		'event': 'promoModuleLink', 
	  	'eventCategory': 'Promotion module',
	  	'eventAction': 'Click',
	  	'eventLabel': linkLocation+" | "+clickText+" | "+clickUrl
	});
});
</script>
	
	
	
	
	
	
	    <div class="apart-alt tags">
	    <span class="related">Related: </span>
	    <ul>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/fraud"><span class="primary-cat-name2">Fraud</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/cyberwarfare"><span class="primary-cat-name2">Cyber Attacks</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/malware"><span class="primary-cat-name2">Malware</span></a></li>
			
				<li><a class="edition-link-url primary-cat-url2" href="/category/security"><span class="primary-cat-name2">Security</span></a></li>
			 
			
				
				
					 
						 
				    				
					
				
					
			
	    </ul>
	   
		</div>
	
	
	
	
	
	
	
	
	
			
	   		











	
	
	
		<div class="byline vcard author end-byline">	
			<div class="author-info">
					<p class="bio">Lucian Constantin is a senior writer at CSO, covering information security, privacy, and data protection.</p>
			</div><!-- end .author-info -->
			
			<div class="brand-social">
				<div class="follow-text">Follow</div>
				<ul class="social-links">
					<li>
						<a href="/author/Lucian-Constantin/">
							<i class="ss-icon ss-user"></i>
						</a>
					</li>
					
						<li>
							<a href="mailto:lucian_constantin@idg.com">
								<i class="ss-icon ss-mail"></i>
							</a>
						</li>
					
					
						<li>
							<a href="https://twitter.com/lconstantin" class="twitter-follow" target="_blank">
								<i class="ss-icon ss-social ss-twitter"></i>
							</a>
						</li>
					
					
					
						<li>
							<a href="https://www.linkedin.com/in/lconstantin" class="linkedin-follow" target="_blank">
								<i class="ss-icon ss-social ss-linkedin"></i>
							</a>
						</li>
					
					
						<li>
							<a href="/author/Lucian-Constantin/index.rss" class="rss">
								<i class="ss-icon ss-social ss-rss"></i>
							</a>
						</li>
					
				</ul>
			</div>			
		</div>
	



	   		
	   		
			
	
	
	
	
		












	
	


<script>
//set business unit / publisher: US / global is default
var contentCopyright = "IDG Communications, Inc.";
var contentEdition = "";
// if there's an article locale ID, use that to get the business unit / publisher for copyright (empty string is global)
if ( contentEdition != "" || contentEdition != null ) {
	// get locale slug of article (contentEdition)
	 contentEdition = "";
	if (contentEdition === 'us') {
		contentCopyright = "IDG Communications, Inc.";
	}
	if (contentEdition === 'asean') {
		contentCopyright = "IDG Communications, Inc.";
	}
	if (contentEdition === 'mideast' || contentEdition === 'middle-east') {
		contentCopyright = "";
	}
	if (contentEdition === 'uk') {
		contentCopyright = "IDG Communications Ltd.";
	}
	if (contentEdition === 'au') {
		contentCopyright = "IDG Communications. ABN 14 001 592 650";
	}
	if (contentEdition === 'nz') {
		contentCopyright = "IDG Communications. ABN 14 001 592 650";
	}
	if (contentEdition === 'in') {
		contentCopyright = "IDG Media Private Ltd";
	}
}
$(document).ready(function() {
	if (contentCopyright != null && contentCopyright != "") {
		document.querySelector("span.ccbu").textContent = contentCopyright;
	}
});
</script>


	<p class="content-copy">Copyright &copy; 2019 <span class="ccbu">IDG Communications, Inc.</span></p>

	
		 
	
	
	
	
	
		
		
	

















	 
	



	
	
	
	
	
	












	
	
	
	
	
	
	
	
	
	
	
	
	
	
	
		<!-- blx4 #1174 blox4.html  -->
			

		
			
				
					
					
					
						
							
					
						
					
					
					
					
					
					
						
					
				
				
			
		















	
	<div class="article-intercept">
	<i class="ss-icon ss-lightbulb"></i> <a href="https://www.csoonline.com/newsletters/signup.html">Get the best of CSO ... delivered. Sign up for our FREE email newsletters!</a>                                 
	</div>
	

	





<script src="/www/js/video/embedder-jwp.js?v=20190924111950"></script>


	
	
	
	




					










				
			
		
		</section><!-- /.bodee -->

		















	
		
			
				
					











<script>var suppressEd = false;</script>

	<script>
		if (countryCode !== "" && (countryCode === 'in' || countryCode === "africa")) {
			suppressEd = true;
			$("div#content-recommender").remove();
		}
	</script>







<div id="content-recommender">
	<div class="OUTBRAIN" data-widget-id="AR_1" data-ob-template="CSOOnline"></div>  
</div>
<script>
	var obEdition = edition ||  countryCode || '';
	var widgetId="";
	
	if (obEdition === "asean") {
		widgetId="AR_3";
		if ($("body").hasClass("slideshow")) {
			widgetId="AR_4";
		}
	}
	if (widgetId !== "") {
		$(".OUTBRAIN").attr("data-widget-id", widgetId);
	}
	// suppressed for certain editions
	if (!suppressEd) {
		$.getScript("//widgets.outbrain.com/outbrain.js");
	}
</script>


				
				
			
			
		

		
			
			
		
			
				
					<div class="lazyload_ad">
						<code type="text/javascript">
						<!--
						var slotName = 'bottomleaderboard';
						var slotSize = [];
						if ($thm.deviceClass == 'mobile') {
							slotSize = [[300,50],[320,50],[300,250]];
						}
						else if ($thm.deviceClass == 'tablet') {
							slotSize = [[728,90],[468,60]];
						}
						else {
							slotSize = [[728,90],[970,90],[970,250]];
						}
						IDG.GPT.addDisplayedAd(slotName, "true");
						document.write('<div id="' + slotName + '" class="ad-container">');
						consent.ads.queue.push(function(){
							IDG.GPT.defineGoogleTagSlot(slotName, slotSize, false, true);});
						document.write('</div>');
						consent.ads.queue.push(function(){
							$('#' + slotName).responsiveAd({screenSize:'971 1115', scriptTags: []}, true);});
						//-->
						</code>
					</div>
							
	
	


	
		










<link rel="stylesheet" href="/www.idgcsmb/css/tso-links.css?v=20190924111950" />

	<div id="tso-wrapper"><div id="tso" style="display:none"></div></div>
	<script type="text/javascript">
	function renderTSO(ads, requireHttps) {
		$thm.debug("renderTSO:"+ads.length);
		if (ads && ads.length > 0) {
			var selectedAds = selectTSOAds(ads,10);
			if (null != selectedAds && selectedAds.length > 0) {
				var html = "<h3>Sponsored Links</h3>";
				html += "<ul>";
				for (var i=0; i<selectedAds.length;i++) {
					html += "<li>";
					html += "<a href='"+selectedAds[i].url+"'> "+selectedAds[i].title+"</a>";
					if (null != selectedAds[i].pixel && selectedAds[i].pixel.length > 0 && selectedAds[i].pixel.indexOf('http') == 0) {
						if(!requireHttps || selectedAds[i].pixel.indexOf('https://') == 0){
							html += "<img src='"+selectedAds[i].pixel+"' style='height:0;width:0;'/>";
						}
					}
					html += "</li>";
				}
				html += "</ul>";
				$("#tso").html(html).show();
			}
		}
	}
	function selectTSOAds(ads,max) {
		if (ads.length <= max) {
			return ads;
		} else {
			var uniq = {};
			var found = 0;
			var selectedAds = [];
			while (found < max) {
				var ad = ads[Math.floor(Math.random()*ads.length)];
				if (uniq[ad.id] != null) {
					continue;
				} else {
					uniq[ad.id] = true;
					found++;
					selectedAds.push(ad);
				}
			}
			return selectedAds;
		}
		return null;
	}
	</script>
	

	
	


		</article>

	</section><!-- /role=main -->

	
	
	

</div><!-- /#page-wrapper -->
		
		












	<link rel="stylesheet" href="/www.idge/css/foot.css?v=20190924111950" />
	<link rel="stylesheet" href="/www.idge.cso/css/foot.css?v=20190924111950" />

<footer>
    <section class="brand" itemscope itemtype="http://schema.org/Organization">
   	
   		<link itemprop="url" href="http://www.csoonline.com"> 
        <a href="/"><span class="logo">CSO Online</span></a>
		<span class="tagline"> CSO provides news, analysis and research on security and risk management</span>
        
        
	        <span class="follow">
				<label>Follow us</label>
	            	<ul>
	            		














	
		<li><a class="social-media-tw-foot" href="https://twitter.com/csoonline" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Twitter')"><i class="ss-icon ss-social-circle ss-twitter"></i></a></li>
	
	
	
		<li class="lnkdn"><a class="social-media-li-foot" href="http://www.linkedin.com/company/csoonline" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('LinkedIn')"><i class="ss-icon ss-social-circle brand ss-linkedin"></i></a></li>
	
	
	
		<li><a class="social-media-fb-foot" href="https://www.facebook.com/CSOonline" itemprop="sameAs" rel="nofollow" target="_blank" onclick="brandFollowTrack('Facebook')"><i class="ss-icon ss-social-circle brand ss-facebook"></i></a></li>				
	
	
	
	
	
	
	
		<li><a href="/index.rss" target="_blank"><i class="ss-icon ss-social-circle ss-rss"></i></a></li>
	
	
	
	
		<script>
			if (typeof facebookUrl !== "undefined" && facebookUrl !== null && facebookUrl !== "") {
				document.querySelector(".social-media-fb-foot").setAttribute("href", facebookUrl);
			}
			if (typeof twitterUrl !== "undefined" && twitterUrl !== null && twitterUrl != "") {
				document.querySelector(".social-media-tw-foot").setAttribute("href", twitterUrl);
			}
			if (typeof youTubeUrl !== "undefined" && youTubeUrl !== null && youTubeUrl !== "") {
				if (document.querySelector(".social-media-yt-foot") !== null) {
		    		document.querySelector(".social-media-yt-foot").setAttribute("href", youTubeUrl);
				} else {
					if (typeof countryCode !== 'undefined' && countryCode === "in") {
        				youTubeUrl = "";
        			}
					$( "<li class='ytbe'><a class='social-media-yt-foot' href='"+youTubeUrl+"' rel='nofollow' target='_blank'><i class='ss-icon ss-social-circle brand ss-youtube'></i></a></li>" ).insertAfter("li.lnkdn");
				}
			}
			if (document.querySelector(".social-media-li-foot") != null) {
				if (typeof linkedInUrl !== "undefined" && linkedInUrl !== null && linkedInUrl !== "") {
					document.querySelector(".social-media-li-foot").setAttribute("href", linkedInUrl);
				}  else {
		    		$("li.lnkdn").hide();
		    	}
			}
		</script>
	


	            	</ul>
	        </span>
        
        
    </section>
    
    
    <section class="about">
		<div class="wrapper"> 
        	<nav class="tertiary" id="ft3">
            	<ul>
            		
















<li><a class="edition-link-url" href="/about/about.html"  >About Us</a>

<li><a class="edition-link-url" href="/about/contactus.html"  >Contact</a>

<li><a class="edition-link-url" href="/about/privacy.html"  >Privacy Policy</a>

<li><a class="edition-link-url" href="/about/cookie-policy.html"  >Cookie Policy</a>

<li><a class="edition-link-url" href="/about/member-preferences.html"  >Member Preferences</a>

<li><a class="edition-link-url" href="https://www.idg.com/advertise-with-us/cso/" target="_blank" rel="nofollow" >Advertising</a>

<li><a class="edition-link-url" href="https://www.idg.com/work-here/" target="_blank" rel="nofollow" >IDG Careers</a>

<li><a class="edition-link-url" href="/about/adchoices.html"  >Ad Choices</a>

<li><a class="edition-link-url" href="/about/affiliates.html"  >E-commerce Links</a>




            	</ul>
        	</nav>
		</div>
	</section>
	
    <section class="copyright">
        <div class="wrapper">
			
        	
        		<img src="https://alt.idgesg.net/images/logos/logo-footer-white.png" alt="IDG Communications" />
        	
        
        	
        	<p><a href="/about/tos.html">Copyright</a> &copy; 2019 <span class="bu">IDG Communications, Inc.</span></p>
			<div class="network">
				<div id="network-selector">
                <div class="label">Explore the IDG Network <i class="ss-icon tick">descend</i></div>
                <ul>
                	
                		
                		
                	














	
		<li><a href="https://www.cio.com" target="_blank" rel="nofollow">CIO</a></li>
	
		<li><a href="https://www.computerworld.com" target="_blank" rel="nofollow">Computerworld</a></li>
	
		<li><a href="https://www.csoonline.com" target="_blank" rel="nofollow">CSO</a></li>
	
		<li><a href="https://www.idc.com" target="_blank" rel="nofollow">IDC</a></li>
	
		<li><a href="https://www.idg.com" target="_blank" rel="nofollow">IDG</a></li>
	
		<li><a href="https://www.idgconnect.com" target="_blank" rel="nofollow">IDG Connect</a></li>
	
		<li><a href="https://www.infoworld.com" target="_blank" rel="nofollow">InfoWorld</a></li>
	
		<li><a href="https://www.idginsiderpro.com" target="_blank" rel="nofollow">Insider Pro</a></li>
	
		<li><a href="https://www.itwhitepapers.com" target="_blank" rel="nofollow">ITwhitepapers</a></li>
	
		<li><a href="https://www.javaworld.com" target="_blank" rel="nofollow">JavaWorld</a></li>
	
		<li><a href="https://www.networkworld.com" target="_blank" rel="nofollow">Network World</a></li>
	

                </ul>
				</div><!-- /#network-selector -->
			</div><!-- /.network -->
		</div><!-- /.wrapper -->
    </section>
</footer>


<script src="/www/js/jquery/jquery-ui.js"></script>
<script src="/www/js/jquery/jquery.dfp.min.js"></script>
<script src="/www.idge/js/mule/shortstack_nav.js"></script>




	
		
			
		





















	

		
			
			
			
			
			
			
				<div id="mobilewelcomead" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("mobilewelcomead", "true");
					$('#mobilewelcomead').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: mobilewelcomead - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
	




<script src="/www/js/analytics/tracking.js"></script>
<script src="/www/js/autocomplete.js"></script>


	<script src="/www.idge/js/jquery/plugins/jquery.colorbox-min.js"></script>
	<script src="/www.idge/js/article.js?v=20190924111950"></script>
	
	<script src="/www/js/prettify.js"></script>
	<script src="/www.idge/js/jquery/responsive-tables.js"></script>
	<script src="/www.idge/js/jquery/jquery.tablesorter.min.js"></script>
	<script>
	$(document).ready(function() {
		$("table.tablesorter").tablesorter({
			widgets: ['zebra']
		});
		
		$("table.tablesorter tbody tr").hover(function() {
			$(this).toggleClass("selected");
		});
		
		$("table.tablesorter thead tr th").each(function(){			
			if ($(this).find('.ss-icon').length < 1) {
				$(this).append('<i class="ss-icon"></i>');
			}
		});
		
	});
	</script>




<script src="/www/js/jquery/jquery.lazyload.min.js"></script>
<script src="/www.idge/js/global.js?v=20190924111950"></script>
<script src="/www/js/webfonts/ss-social.js"></script>
<script src="/www/js/webfonts/ss-standard.js"></script>
<script src="/www/js/analytics/brandAnalytics.js"></script>
















	<script src="/www/js/locales-editions-slug.js?v=20190924111950"></script>





		
		
			
				
			





















	

		
			
			
			
			
			
			
				<div id="catfish" class=" ad-container test">					
				</div>				
				<script type="text/javascript">
				consent.ads.queue.push(function(){
				
					IDG.GPT.addDisplayedAd("catfish", "true");
					$('#catfish').responsiveAd({screenSize:'971 1115', scriptTags: []});
                    IDG.GPT.log("Creating ad: catfish - [971 1115]");
                    
				
				});
				</script>
			
		
	
 	
 
 
			
				
			





















	

		
			
			
				<!--  Begin gpt-skin -->
				<div id="gpt-skin" class=" ad-container">					
				</div>
				<script type="text/javascript">
				consent.ads.queue.push(function(){
					IDG.GPT.addDisplayedAd("gpt-skin", "true");
					IDG.GPT.displayGoogleTagSlot('gpt-skin');
				});
				</script>
				<!--  End gpt-skin -->	
			
			
			
			
			
		
	
 	
 
 
		
	



<script type="text/javascript" src="/www/js/ads/jquery.lazyload-ad.js"></script>


<script type="text/javascript">
// -- Load Lazy Advertisement placement as deferred
$("div.lazyload_ad").lazyLoadAd({
        threshold    : 0,         // You can set threshold on how close to the edge ad should come before it is loaded. Default is 0 (when it is visible).
        forceLoad    : false,       // Ad is loaded even if not visible. Default is false.
        onLoad       : false,       // Callback function on call ad loading
        onComplete   : false,       // Callback function when load is loaded
        timeout      : 1500,        // Timeout ad load
        debug        : false,       // For debug use : draw colors border depends on load status
        xray         : false        // For debug use : display a complete page view with ad placements
}) ;
</script>







<script type='text/javascript'>

	var ocHead = $("#oc-head").outerHeight();
	var relatedContentHeight = $(".related-content-wrapper").outerHeight();
	relatedTop = ocHead+50;
		$(document).ready(function() {
			function debounce(func, wait, immediate){
			    var timeout;
			    return function(){
			        var context = this, args = arguments;
			        var later = function(){
			            timeout = null;
			            if (!immediate) func.apply(context, args);
			        };
			        var callNow = immediate && !timeout;
			        clearTimeout(timeout);
			        timeout = setTimeout(later, wait);
			        if (callNow) func.apply(context, args);
			    };
			}
			
			 var lastScrollTop = 0;
			 
			 if (window.addEventListener) {
		        window.addEventListener('scroll', debounce(function(e){
		        
		        var containerOffset = $("#drr-container p:last").offset().top;
			    var containerHeight = $("#drr-container p:last").outerHeight();
			    var windowHeight = $(window).height();
			    var windowScrolltop = $(this).scrollTop();

			    if (windowScrolltop > lastScrollTop) {
			    	// user is scrolling DOWN: hide ribbon
			    	$(".related-content-wrapper").css('top','-'+relatedTop+'px');
			    	
		    	 	if ((windowScrolltop > (containerOffset+containerHeight-windowHeight))&& !($('#oc-head').hasClass('no-stick-important'))) {
			    		// user is scrolling down and sees last paragraph: show ribbon
			    		$(".related-content-wrapper").css('top',ocHead+'px');
		    		}
			    	
			    } else {		        	
			    	$(".related-content-wrapper").css('top','-'+relatedTop+'px');
			    }
			   
			   	lastScrollTop = windowScrolltop;
					
		               
		        }, 5));   // run maximum of one time every 5ms
		    }
		    
		});
	

	g_bRequireHttps = true;
	 	var localeId = getLocale();
		$.ajax('/ads/tso?localeId=' + localeId,{
			dataType: 'json',
			success: function(data){
				renderTSO(data.tsoLinks, g_bRequireHttps);
			},
			error: function(jqXHR,error,thrown){
				$thm.debug("TSO AJAX Status: "+error+": "+thrown,true);
			}
		});
	
</script>












	
		
	
	
		
	
	

<!-- Begin comScore Tag -->
<script>
var _comscore = _comscore || [];
_comscore.push(
{ c1: "2", c2: "6035308", c3: "", c5: "Fraud", c6: "Article: News", c15: "3440580" });
(function()
{
	var s = document.createElement("script"), el = document.getElementsByTagName("script")[0];
	s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
	el.parentNode.insertBefore(s, el);
})();
</script>
<noscript>
<img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035308&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	<!-- LiveRamp Sources -->
	<script src="/www/js/utils/liveRamp.js"></script>
	<!-- End of LiveRamp -->













<script type="text/javascript">
consent.digitalelement.queue.push(function(){
	$thm.logPlEvent({"b":"cso","e":"view","t":"article","id":"3440580"});
});
</script>

		<div id="loginModal"></div>
		<div id="logoffModal"></div>

		
		
		
		<script type="text/javascript">
			a=top;f=self;
			var acceptedDomains = ["lookbookhq.com"];
			var cleanedHost = a.location.hostname.split(".").slice(-2).join(".");
			if(a!=f && acceptedDomains.indexOf(cleanedHost) < 0) {
				a.location=f.location;
			}
		</script>			

	</body>
</html>